locked
Opening attributes to edit very slow RRS feed

  • Question

  • Opening an attribute to edit is very slow. It hangs on a white screen for a couple of minutes while load the attribute window.

    Any thoughts?


    Thanks, Scott Coates North America Traffic
    Monday, May 31, 2010 7:20 PM

Answers

  • Try running Fiddler when the page loads slowly and see what you find.  I've found that when I see a delay, it is usually associated with caching in IE.  The delay occurs when the cache needs to be updated.  I think that is why you see the page display more quickly the second time you access the attribute.  The first attempt to access required an update to cache and the second attempt was able to pull from cache so it was much quicker.

    Have a read through this article (quick read) and you might glean some information that helps speed up IE for you.

    Also, I had a few users who were having the same type of issue, so I monitored their processor, memory etc., when hitting the CRM server vs. opening other Internet sites, and found that the processor was hitting and holding at a high level.  I went through a round a applying all OS and Office updates, cleared their cache, removed all IE toolbars and add-ons, and made a few other adjustments to their system and it helped.  One user's system was really dragging so I upgraded that user to Windows 7 and that fixed the issue.   

     


    Regards, Donna

            Windows Live Blog

    • Marked as answer by Jim Glass Jr Tuesday, June 1, 2010 4:04 PM
    Tuesday, June 1, 2010 4:01 PM

All replies

  • What is your server's configuration?
    Tuesday, June 1, 2010 6:52 AM
  • I have a SBS 2003 running SQL 2005, Exchange, Infor Visual, Domain, etc.

    I have a Windows 2008 Server running CRM

     

    Also, It only seam to happen when I open the first attribute to edit after I open the entity. Any further attributes I open load fine.


    Thanks, Scott Coates North America Traffic
    Tuesday, June 1, 2010 12:44 PM
  • This could be a caching issue or possibly virus protection.  Ensure the CRM URL is added to the Trusted sites on the machine, that your IE settings are configured to "Automatically Check for Newer Version of the Pages (Tools, Internet Options, Browsing History, Settings), and that your virus scan settings are configured to not scan CRM related pages. 


    Regards, Donna

            Windows Live Blog

    Tuesday, June 1, 2010 1:11 PM
  • Hi Donna,

    Check my IE settings and it is correct.

    Turned off my AV web scanner.

    No Change


    Thanks, Scott Coates North America Traffic
    Tuesday, June 1, 2010 2:57 PM
  • Try running Fiddler when the page loads slowly and see what you find.  I've found that when I see a delay, it is usually associated with caching in IE.  The delay occurs when the cache needs to be updated.  I think that is why you see the page display more quickly the second time you access the attribute.  The first attempt to access required an update to cache and the second attempt was able to pull from cache so it was much quicker.

    Have a read through this article (quick read) and you might glean some information that helps speed up IE for you.

    Also, I had a few users who were having the same type of issue, so I monitored their processor, memory etc., when hitting the CRM server vs. opening other Internet sites, and found that the processor was hitting and holding at a high level.  I went through a round a applying all OS and Office updates, cleared their cache, removed all IE toolbars and add-ons, and made a few other adjustments to their system and it helped.  One user's system was really dragging so I upgraded that user to Windows 7 and that fixed the issue.   

     


    Regards, Donna

            Windows Live Blog

    • Marked as answer by Jim Glass Jr Tuesday, June 1, 2010 4:04 PM
    Tuesday, June 1, 2010 4:01 PM
  • HI Donna,

     

    I made the IE changes, and it did help a bit, but not significantly.

    There is a higher spike with CRM page load then normal IE page loads. But by no means am I close to my full CPU usage.

    I have tried Fiddler, not sure what to look for but I am seeing this:

    .REQUEST { font: 8pt Courier New; color: blue;} .RESPONSE { font: 8pt Courier New; color: green;} HTTP/1.1 200 OK
    Cache-Control: no-cache
    Pragma: no-cache
    Content-Type: text/html; charset=utf-8
    Content-Encoding: gzip
    Expires: -1
    Vary: Accept-Encoding
    Server: Microsoft-IIS/7.0
    X-AspNet-Version: 2.0.50727
    X-Powered-By: ASP.NET
    WWW-Authenticate: Negotiate oYG2MIGzoAMKAQChCwYJKoZIgvcSAQICooGeBIGbYIGYBgkqhkiG9xIBAgICAG+BiDCBhaADAgEFoQMCAQ+ieTB3oAMCARKicARuLgA07J4Qd/JBjznI4bphrt1DSEvl2E8Aw7YKSEin1zn7FHtErsG4qaeJtx9upU1FeVjSerVbUxTGMggdaskKAhSLk1WdJfHAQzHazi8d6+yuWu75tHyNWOG94CvAjxYwY0wme04bcbPY7Bxg6gk=
    Date: Tue, 01 Jun 2010 18:19:42 GMT
    Content-Length: 8050

    ?

    Thanks, Scott Coates North America Traffic
    Tuesday, June 1, 2010 6:27 PM
  • Hi Scott,

    Have a look at articles to learn more about how to use Fiddler.

    Fiddler PowerToy - Part 1: HTTP Debugging

    Introducing Fiddler

    Debug Web Sites With Microsoft's Fiddler Powertoy


    Regards, Donna

            Windows Live Blog

    Tuesday, June 1, 2010 7:31 PM