locked
Ghost bad sectors on WHS system drives over 1TB and IDE vs. AHCI - a consolidated thread RRS feed

  • Question

  • I've posted a couple of times and continue to get the "it's your hardware/drivers" runaround.  With a 1.5TB drive as system drive it would format and work just fine on a Win7 machine but, in about a week, the WHS Console would complain about the disk being unhealthy and chkdsk would show 390GB of bad sectors in WHS.  Swapped out for a 2TB drive figuring the 1.5TB was truly going bad (it still goes strong back in my Win7 machine - reformat = no bad sectors) and was shocked to see nearly 900GB of bad sectors!  Same thing:  Moved off to Win7, reformat, worked fine.  Swapped out motherboard, same results.  Changed SATA cables, same results.  Got a beefier PSU, same results.

    The one commonality between the two machines is both ran SATA in IDE mode.  It is CLEAR from all these posts and others in the Windows forums about mysterious bad sectors on Server 2003 that it's Server 2003, even with SP2, that's the issue.  One hotfix from 4 yrs ago acknowledges the issue with drives >1TB but that hotfix was supposedly included in SP2.  Now, my WHS install disc is SP1 so it might have the problem straight off, and SP2 doesn't resolve it?  I don't know.

    From all these posts it appears switching to AHCI fixes the problem.  Unfortunately the new mobo I put in is Intel ICH7 which has 4 SATA ports but no RAID/AHCI support, just IDE compatibility mode support.

    My current setup:  I put a 500GB HDD in as the system drive.  No errors reported for about 2 wks now, even though I have 1 1.5TB and 2 2TB data drives in the server.  So it APPEARS to only be an issue for the system volume.  But I am nervous about all my data potentially disappearing one day on those DATA volumes, and will likely get another motherboard that offers AHCI support.  It appears from other posts like you can simply update the SATA drivers in WHS via RDP, reboot, change the bus mode in BIOS, and you should be up and running.  Any opinions on this?  Otherwise I'm going the Slipstream route indicated above - but afraid that it won't allow me to do a "Server Reinstall" based upon the change from IDE to AHCI.

    So why, with all these posts out there regarding this issue with "ghost" bad sectors, doesn't Windows and this forum's moderators acknowledge, and put a full official post on, the fact that Windows Server 2003 SP2 does not support HDD over 1 TB???  Sure it technically IS a driver issue, but it runs deeper than that if we're talking a communication format (sic) change from IDE to AHCI.

    To summarize, WHS builders beware:  This product, and WS2003, was built before the age of large-capacity hard drives!!  Install with your drives in AHCI mode, which also adds NCQ features and purportedly makes drive seeks more efficient and consume less power (read: run cooler), which on a few posts appears to have solved the problem.

    Here are the related threads I've found on this topic:

    http://social.microsoft.com/Forums/en/whshardware/thread/c36d7aa9-50d4-4af7-9ff9-dd465f31216d

    http://social.microsoft.com/Forums/en/whshardware/thread/2b617c8f-c32e-4cfe-a275-4764d77a7da9

    http://social.microsoft.com/Forums/en-US/whssoftware/thread/9d605f70-9693-4b17-8ab9-d44a39dab72b

    I think there may have been one or two more, but those may have been inconclusive as to the root cause.

    And here is the official Microsoft post and hotfix about drives over 1TB on Server 2003:

    http://support.microsoft.com/kb/906668/en-us

    Finally, for those more technically inclined, a new WHS install may be easier with AHCI drivers slipstreamed in, and this MIGHT allow you to do a Server Reinstall with existing DATA drives if originally installed in IDE mode (most of us, I'm sure) and switching to AHCI - I have yet to test this b/c I need another new motherboard.

    http://wiki.wegotserved.com/index.php?title=Slipstream_Windows_Home_Server

    I hope this is helpful!

     

    Tuesday, November 9, 2010 5:50 PM

All replies

  • Thank you! This may be the cause of my issues. It seems to have slowly crept up on my since I updated from 1TB drives to 2TB drives. It ran great from the start, now I'm getting phantom "system" files conuming a large amount of space even though I can't account for that space. Random slow transfers. Chkdsk is reporting bad sectors now on all my drives with data exceeding 1TB. I plan on reformatting and reinstalling WHS with AHCI enabled, it looks like my mobo supports it. Perhaps I didn't need to RMA one drive already.
    Monday, January 10, 2011 5:19 PM
  • My current setup:  I put a 500GB HDD in as the system drive.  No errors reported for about 2 wks now, even though I have 1 1.5TB and 2 2TB data drives in the server.  So it APPEARS to only be an issue for the system volume. 

    Nice post and thanks for the warning.

    I'm using six 2TB drives in IDE mode, connected to the motherboard, for the storage pool only.  System drive is connected to a RAID card set-up as RAID 1.  I've had zero issues with bad sectors. 

    This may just only be a system drive issue for drives larger than 1TB running in IDE mode.  When in doubt, use AHCI.

    Tuesday, January 11, 2011 12:52 AM