locked
Unable to connect to Dynamics CRM Server from VS2012 RRS feed

  • Question

  • Hi All,

    I am having trouble authenticating to an on-premise instance of Dynamics CRM 2013 through the wizard within Visual Studio 2012.

    I have been tasked with developing a plugin, so I have installed the CRM 2013 SDK for VS2012 and have created a solution using the 'Solution Template for Dynamics CRM 2013'.  Naturally on creation of the solution I was prompter to fill out the 'Connect to Dynamics CRM Server' dialog.  I entered the 'CRM Discovery Server Name', which manages to connect just fine.  When I enter the username, password and domain however (which I am doubly sure are all correct as I can log in through the browser with them, and for the record are administrative credentials) I get the following error -

    "At least one security token in the message could not be validated"

    A quick google on this indicates that it is a WCF related issue, however I was just wondering if any of you have come across this issue before in the context of 'Microsoft Dynamics CRM' and if so what you did to resolve it?

    Many thanks in advance.


    Friday, July 31, 2015 10:46 AM

Answers

  • I ended up resolving this issue very simply by including the domain in the 'User name' field instead of the 'Domain' field (i.e. in the format Domain\User), leaving the domain field blank.

    I am not sure if this is a bug in the wizard, however this fixed the issue for me.

    • Marked as answer by WombleNumber1 Friday, July 31, 2015 3:13 PM
    Friday, July 31, 2015 3:13 PM

All replies

  • Hi,

    Turn on WCF trace at the server side and check the error message. You should do this first, sometimes it gives you exact error.

    Install Fiddler, and check the issue/error info from there also.

    Thanks.

    Friday, July 31, 2015 1:14 PM
  • I ended up resolving this issue very simply by including the domain in the 'User name' field instead of the 'Domain' field (i.e. in the format Domain\User), leaving the domain field blank.

    I am not sure if this is a bug in the wizard, however this fixed the issue for me.

    • Marked as answer by WombleNumber1 Friday, July 31, 2015 3:13 PM
    Friday, July 31, 2015 3:13 PM