Canon MP210 Incompatibility Issue RRS feed

  • General discussion

  • After about 30 hours of troubleshooting an error with my Canon Pixma MP210, I've come to the conclusion that there's an incompatibility issue with the Vista operating system updates.  Here is as summary of the issue and my troubleshooting steps:



    • Normal operation:  When checking printer status, a "Status Request" task is queued in the spooler.  This task is not a print request, per se, but triggers the printer to send a status message to the status monitor.  The status monitor displays "Collecting printer status..." until the message is returned. 
    • When the error occurs:  The "Collecting printer status..." message never goes away.  Neither does the "Status Request" task.  The job cannot be deleted, even directly from the system folder.  In fact, when shutting down the computer, (in my case a Dell Inspiron 1501 laptop) the system will not shut down.  At best, it blue-screens, but either way, I'm forced to cold-kill the computer to get it to power down.

    Troubleshooting steps:

    • Tried disabling all services except Microsoft services - no joy
    • Booted in Safe mode with only the print driver loaded - printer worked
    • Tried disabling firewalls (including One Care and the Windows firewalls) - no joy
    • Reinstalled Vista from scratch (what a pain!!) - printer worked
    • Installed SP1 - no joy
    • Uninstalled SP1 - printer worked
    • Installed Automatic Updates - checking to be sure SP1 was not included - no joy

    There is bound to be something that can be done to stop my printer from locking up my computer and that will allow me to continue using Vista at its latest and greatest.  I'm simply informing the One Care world of my personal quest and if anyone has similar issues - and especially if anyone finds a resolution! - please post a reply!

    Tuesday, April 29, 2008 11:32 PM

All replies

  • Since you're using OneCare and have mentioned that disabling OneCare makes no difference in the ability to print, you're not really off topic, so I moved your post to the General folder. Have you contacted Canon about this problem?



    Wednesday, April 30, 2008 5:03 PM
  • Sorry about the misunderstanding of the definition of "off topic".  At any rate, yes, I had a lengthy intercourse via email with Canon, and some phone calls to Dell, all to no avail.  Canon's final comment/suggestion was that they were unaware of any compatibility issues with any of their Pixma series printers and Vista and that I should call their technicians.  I decided I'd done enough troubleshooting.  Short of suggesting that I load the 36 updates to try to find the offender, I'm not sure what else a technician could have me do that I haven't done. Frankly, it seems odd that I'm the only one in the world with this issue...??


    My final resolution was to go back to the store and return the confounded thing and buy an HP.  It seems to work just fine, thank you.  I, personally, no longer have an incompatibility issue.  It could have been some fluke in my BIOS or who knows what - computers are quirky beasts.  This one simply didn't want to talk to Pixma.  I'd actually prefer that someone else in the world also have the same issue so that it could be resolved rather than remain an enigma...

    Thursday, May 1, 2008 3:40 AM
  • Yes, computers can certainly make life interesting when they don't work like we think they should. I can't offer any ideas why the Canon didn't work with your PC, especially since both Canon and Dell were not able to help.

    Maybe someone else will find your thread and reply. In the meantime, I'm glad you resolved it, albeit with an exchange and after much time spent troubleshooting. And, no problems on the off topic placement. It's just that we don't really intend that folder for discussions. We use it to move posts out of the topic folders that are totally unrelated to OneCare as those posts cloud the statistics Microsoft gleans from the forum activity. We decided that having a place to move the posts and provide direction to the person posting the off topic query was better than deleting the posts outright. :-)



    Thursday, May 1, 2008 2:42 PM
  • I also have a Dell Inspiron 1501 installed with Vista but use a Canon MP600


    I'm also having the same problem with "collecting printer status".


    It all worked fine in the beginning but after about 8 months this message started to be displayed.  Now its hit or miss if I can get the printer to work.  Its driving me nuts.  I use my printer for work and sometimes have to print 20 or 30 double sided copies of a document.  The only way I can get it to work is to put loads of stuff in the print queue and then restart.  Once the machine fires up again all the documents in the print queue come flying out of the printer.  Its very frustrating.  I've updated, played with the firewall, uninstalled and reinstalled the printer software, scoured the cannon website for ideas and am now hitting my head against a brick wall.  Its nice to know i'm not alone.



    Tuesday, July 15, 2008 1:30 PM
  • Are you also using OneCare, Debs? And disabling OneCare's firewall and/or virus and spyware protection makes no difference?



    Tuesday, July 15, 2008 1:53 PM
  • No.  i'm using AVG  but disabling that didnt make any difference either.


    i'm going to spend some time on it tomorrow - strip the machine software back to basics and reload one at a time to try to find the problem.  time consuming but I really dont want to have to buy another printer.

    Tuesday, July 15, 2008 6:26 PM
  • Might want to take a look at the following page:




    I also found a case where someone simply shutdown the PC, turned the printer off, restarted the PC with it off, then shutdown the PC and started it up again. After the PC had come up and been logged into an Administrator Account, they simply turned on the printer which caused the system to find the 'new' hardware and re-install it properly.


    Not sure either of these will solve your particular issue, but it sounds like it's a simple issue of the printer not being visible to Windows.



    Tuesday, July 15, 2008 10:34 PM
  • Debs

    The problem didn't occur on my machine until Vista SP1 was installed.  I uninstalled SP1 and it worked fine, but as soon as the automatic updates kicked in, it killed it again.  I don't know which update it was (there were 36 of them and I wasn't interested in installing them one at a time to troubleshoot - I bought a new HP Printer and got on with my life) but it seems that if it worked for about 8 months and then began acting up, I'm betting one of those updates took you down.  I wish I could be of more help, but you're doing exactly what I had to do until I gave up and bought a different printer.

    Wednesday, July 16, 2008 2:41 PM
  • I have today uninstalled and reinstalled AVG, uninstalled and reinstalled the software for the printer, unplugged, restarted, shut down, plugged in and started up the printer/pc and Hey Presto we are back on form.  Let just hope it lasts.


    Thanks for your help - it was just nice to know that I wasnt alone with this issue.




    Wednesday, July 16, 2008 8:43 PM