locked
Adding a SATA Drive RRS feed

  • Question

  • I have successfully installed WHS on an IDE drive, and am trying to add a SATA drive.  When connected and powered, it is not recognized by WHS (the add option remains inactive and grayed out).  I have tried looking in admin tools and it sees my IDE drive (with two partitions - OS and Data) and two dvd drives, but cannot see the SATA drive.

     

    I have an MSI motherboard, and SATA is enabled in the BIOS.

     

    Any advice on getting WHS to see the added drive?

     

    Thanks in advance.

    Monday, March 24, 2008 1:35 PM

Answers

  • The proposed solution worked.  In the BIOS advanced settings, I changed the SATA type to "emulate IDE".  When the server booted up, the SATA drive was visible.  I added two more, and all three showed up in WHS and could then be added.

     

    Thanks for the help!

    Tuesday, March 25, 2008 11:54 AM

All replies

  • Hi,

    You could try changing the setting in the BIOS to 'compatibility mode' or similar; you won't loose much in the way of speed etc. Also, as WHS doesn't have SATA support built-in, you should check if MSI have any SATA drivers, usually, they will be something like "Intel ICH7R/ICH8R SATA RAID Driver " However, you don't want the Raid version, just normal.

     

    HTH,

     

    Colin

     

    Monday, March 24, 2008 4:14 PM
  • Colin:

     

    Thank you for your detailed and helpful reply.

     

     

     

    Monday, March 24, 2008 5:00 PM
  • The proposed solution worked.  In the BIOS advanced settings, I changed the SATA type to "emulate IDE".  When the server booted up, the SATA drive was visible.  I added two more, and all three showed up in WHS and could then be added.

     

    Thanks for the help!

    Tuesday, March 25, 2008 11:54 AM
  • Glad you got it working.

    The compatibility mode really won't effect the server much at all. Plus, it means IF you ever have to replace a disk, you don't have to worry about drivers etc.

     

    Good luck with the rest of it.

     

    Colin 

     

    Tuesday, March 25, 2008 5:43 PM