locked
CRM router mail box always getting stuck RRS feed

  • Question

  • It appears to be a common problem that the email router will get stuck when processing emails, and the fix is to delete the offending email and the processing will resume.

    This is a fine work around, but it is becoming a larger problem.  I have to purge abnormal emails from our forwarder mailbox 20 times a day.

    It appears to get stuck on emails with non-enligh charecters in the subject, or when a single email is delivered to more than one person (for instance if one user has all their emails forwarded to another user.)

    Any suggestions?

    Thursday, July 30, 2009 6:24 PM

Answers

  • What Rollup do you have? Email router shouldn't be acting like what you have described. Without a lot of detail. I would recommend that you open a support ticket with MS support to resolve this issue.
    Darren Liu | 刘嘉鸿 | MS CRM MVP | English Blog: http://msdynamicscrm-e.blogspot.com | Chinese Blog: http://liudarren.spaces.live.com
    Saturday, August 1, 2009 4:13 AM
    Moderator

All replies

  • What Rollup do you have? Email router shouldn't be acting like what you have described. Without a lot of detail. I would recommend that you open a support ticket with MS support to resolve this issue.
    Darren Liu | 刘嘉鸿 | MS CRM MVP | English Blog: http://msdynamicscrm-e.blogspot.com | Chinese Blog: http://liudarren.spaces.live.com
    Saturday, August 1, 2009 4:13 AM
    Moderator
  • Do you have any limits on the mail box used to send email?
    post you email router config, and log files please?
    Tiaan van Niekerk http://crmdelacreme.blogspot.com Skype:tiaan.van.niekerk1
    Saturday, August 1, 2009 5:20 AM
  • It is rollup 4, and there are no limits on teh mailbox.

    I have recently been able to significantly reduce the number of hangups by disabling a catchall email address that was redirecting emails without modifiying the TO fielding.
    Saturday, August 1, 2009 12:24 PM
  • I am finding that we are having a lot of emails placed in the "undeliverable" folder.  The errorposted in the event log is:

    0x80040b05

    At least one system user or queue in the organization must be a recipient


    This is wrong though.  When I look at the email header I see the correct email address of the queue in question.

    Friday, August 7, 2009 6:36 PM
  • Try this!
    Delete the 'Microsoft.Crm.Tools.EmailAgent.SystemState.xml' in C:\program files\microsoft crm email\service and then the service could be startet again.And a new 'Microsoft.Cam.Tools.EmailAgent.SystemState.xml' is created upon start!
    Tiaan van Niekerk http://crmdelacreme.blogspot.com Skype:tiaan.van.niekerk1
    Friday, August 7, 2009 7:02 PM
  • Thank you for your reply.

    I placed a previously "undeliverable" item back into the forwarder mailbox.  This item was previously "undilverable" becasue CRM believed it was not addressed to a user or queue, which is incorrect.

    I then deleted the file you mentioned an restarted the service.  After the service restarted the Systemstate xml was recreated and posted the original error that the email was undeliverable beacuse it did not contain a recipient in the CRM organixation (again, not true).
    Monday, August 10, 2009 6:41 PM
  • Ok, so I have narrowed the issue down a little.

    The email address used for the queue is a catchall for our domain, so if someone tries to email something to our domain and it doesnt match any mailbox then it will go to the queue's email.

    This will obviosuly not work, because CRM is looking for a specific email address.  To get around this problem I have a rule on the mailbox that first checks to see what email address the message was sent to then redirects it to the correct address if it was wrong.

    For some reason, even though the redirected email address is shown in the emails header CRM still believes that the message contains a non-existant email address.

    My temporary solution is to NOT use redirection, and instead I will have the rule forward the email to the correct address.  I dont like doing this being you loose from and CC information, but it will have to be that way until someone can offer a suggestion.
    Tuesday, August 11, 2009 3:34 PM