locked
CRM changes field name when using new 2016 web api RRS feed

  • Question

  • Hi,

    I'm trying to use Web api to get list of entities, and found strange behavior of CRM.

    I have entity - "my_entity" and it has field called the same name "my_entity"

    When i try to use this url: ../api/data/v8.1/my_entities?$filter=my_entity eq 0

    CRM says that there isn't field with name "my_entity", when i tried to select without filter.. i found that field name is changed in this response and it becomes "my_entity1"..

    If i try to use this url: ./api/data/v8.1/my_entities?$filter=Microsoft.Dynamics.CRM.Between(PropertyName=%27my_entity%27,PropertyValues=["0","0"])

    it works!.. But it looks strange to use these api calls in my simple case..

    So why CRM changed field name? And Can i use for example entityName + '1' every time when i want to get fields with name the same as entity name? Or in some cases CRM can add for example '2'...

    Friday, August 12, 2016 9:23 AM

All replies

  • looks like a bug to me, so just to confirm: this happens when the field name is equals to the entity name? did you try with more than 1 custom entity?

    eventually you can fill this bug here https://crmideas.dynamics.com


    My blog: www.crmanswers.net - CRM Theme Generator

    Friday, August 12, 2016 9:37 AM
  • It reproduced at least on 2 old entities (we upgrade our customization to use new Web API).

    Also i tried to create a new entity with only 1 field as i wrote at the first message and it is also reproduced..

    Friday, August 12, 2016 9:45 AM