locked
CqvSvc.exe System.Management.ManagementException 'Invalid class' RRS feed

  • General discussion

  • Just wanted to let you know that I'm getting this message in the application event log every minute. Disabled the service for now. There's something wrong with this CqvSvc.exe.
    Friday, December 18, 2009 2:49 PM

All replies

  • Hi,
    According to this thread the CqvSvc.exe is the Console QuickView Monitor Service (part of the new Media Center functionality).
    Looks like a problem with the installation of PP3?

    - Theo.

    No home server like Home Server
    Friday, December 18, 2009 8:58 PM
    Moderator
  • Hi,
    I did battle a little bit longer with that stuff now after getting the event log flooded with messages from cqvSvc.exe "Initialization failed". Also the health.xml was no longer upgraded.
    Since this happened after an unexpected power outage while powering up and there was also an error with accessing the Repository folder I decided to stop wmimgmt service, delete the folder and reboot the server.
    This fixed another behavior (my Scaleo Home Server could not start the Intel Hardware Monitor any more), but the warning generated by cqvSvc.exe in event log changed to Invalid class. Since I am not a programmer and using Dependency Walker on the exe file did not reveal anything for me, I attempted to uninstall and reinstall the service by the commands:
    C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\installutil /u "C:\Program Files\Windows Home Server\cqvsvc.exe"
    which should successfully remove the service
    C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\installutil /u "C:\Program Files\Windows Home Server\cqvsvc.exe"
    for installing the service again.
    Rebooted - and still the same warning.
    So I decided to run another round in the WMI struggle by executing the following batch (which I had still from another situation, in which I needed to repair WMI on a production server) - put the lines into a file and save it with extension .cmd before executing it on your server - I do not guarantee it working and not destroying anything in your specific installation):

    cd /d c:\temp
    if not exist %windir%\system32\wbem goto TryInstall
    cd /d %windir%\system32\wbem
    net stop winmgmt
    winmgmt /kill
    if exist Rep_bak rd Rep_bak /s /q
    rename Repository Rep_bak
    for %%i in (*.dll) do RegSvr32 -s %%i
    for %%i in (*.exe) do call :FixSrv %%i
    for %%i in (*.mof,*.mfl) do Mofcomp %%i
    net start winmgmt
    goto End

    :FixSrv
    if /I (%1) == (wbemcntl.exe) goto SkipSrv
    if /I (%1) == (wbemtest.exe) goto SkipSrv
    if /I (%1) == (mofcomp.exe) goto SkipSrv
    %1 /RegServer

    :SkipSrv
    goto End

    :TryInstall
    if not exist wmicore.exe goto End
    wmicore /s
    net start winmgmt
    :End
    pause

    After this was completed, I rebooted and did see the warnings happening about 10 minutes long again, but finally after seeing two informations with source LoadPerf in the application log about removal and loading of performance indicators for WmiApRpl (WmiApRpl) the health.xml file in C:\Inetpub\Intranet\health was created again and no more warnings have been shown.

    Best greetings from Germany
    Olaf

    Friday, February 5, 2010 8:50 AM
    Moderator
  • Can you also see if running
    winmgmt /resyncperf
    can solve this problem?

    Thanks.

    Donald
    [MSFT]
    Friday, March 5, 2010 7:51 AM
  • Hi Donald,
    interesting hint - if I should see that issue again on one of my Home Servers, I will definitively try that first :-)
    Best greetings from Germany
    Olaf
    Friday, March 5, 2010 9:09 PM
    Moderator
  • Thanks for the tip. It fixed my problem. Now I get the health.xml file generated and NO error entries in the Event Log.

    Simon
    Friday, March 5, 2010 9:32 PM
  • Have seen another confirmation in the German forums, that this fix was working for the described issue.
    Best greetings from Germany
    Olaf
    Sunday, March 7, 2010 8:21 PM
    Moderator
  •   Worked for me too. Thanks for the tip... was driving me nuts having that many warnings on the log and WMC connector showing "status not available"

     
    Sunday, March 7, 2010 9:59 PM
  • Fantastique!! It's work also for me!! Thanks from France.
    Engel
    Saturday, April 10, 2010 2:37 PM
  • I did the winmgmt /resyncperf and it worked!!!  So far so good!!!
    Wednesday, May 26, 2010 2:11 AM
  • Did you try both fixes?  Do they accomplish the same thing?
    Sunday, May 30, 2010 7:21 PM
  • Did you try both fixes?  Do they accomplish the same thing?


    I think, yes - with my more complex method I accidentially may have touched the problem cause, and Donald did show a shorter method to accomplish this.

    Best greetings from Germany
    Olaf

    Tuesday, June 1, 2010 11:21 AM
    Moderator
  • Thanks -- ran the macro -- worked great.

     

    Cheers

    Mark

    Friday, May 6, 2011 9:41 PM