locked
Images on Customer Portal secured with SSL requires IE "Show all Content" button clicked RRS feed

  • Question

  • After implementing a SSL cert for our Portal, IE requires visitors to "Show all Content" to view two unsecured images, one being the Microsoft Building image as part of the default portal install. 

    I have since removed the images and added them back into the Content Management section in CRM using IFD which is SSL secured, but the issue persists.  Both CRM and Portal are on-prem.

    Any ideas?

    Example #1  Source <p><img style="margin: 10px auto; float: right;" title="C3SD Inc." src="C3SD_Logo_4_CRM_Website.gif" alt="C3SD Inc." /></p>

    Example #2  Source <p style="color: #093d62; font-size: 12pt;"><img style="display: block; margin-left: auto; margin-right: auto;" title="Microsoft Building" src="microsoft-building.jpg" alt="Microsoft Building" width="185" height="123" />&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;</p>


    M Surmanian C3SD Inc.



    Tuesday, June 4, 2013 5:38 AM

All replies

  • You will need to find out which files are triggering the error.  Using IE, hit F12 to open the developer toolbar, then turn on network tracing and visit your site.  Examine all of the requests and find the ones that are only for http and not https.  Then either find the files in your code (templates) or in your content and adjust the urls.  I highly recommend making the urls to use what is known as protocol-relative urls.  Just leave out the http: or https: and the browser will automatically use the current protocol.  Here is a good document on that technique:  http://weblogs.asp.net/jgalloway/archive/2009/10/15/did-you-know-about-protocol-relative-hyperlinks.aspx

    Shan McArthur www.shanmcarthur.net Check out the commercial edition of xRM portals @ www.adxstudio.com

    Thursday, July 4, 2013 7:22 PM
    Moderator