locked
Can't Access Share Folder Contents RRS feed

  • Question

  • My WHS developed a booting problem 2 days ago, which may have been caused by a corrupted ATA system disk.  I assigned an empty SATA drive as the primary disk and did a "re-install" (with the original corrupted system disk still attached).  When I booted up for the first time after the re-install, system displayed several error messages relating to DEUTIL.DLL.  Despite these error messages, system seemed to be working.  I can see all my data drives in the Home Server console, and they're all reported as healthy.  However, when I looked in the shared folders, there's nothing there.  I think the data are still on the disk, but can't be access via the shared folders for some reason.  Console shows I have a total of 2.81 TB of storage with 1.76 TB used.  It shows "System" using 1 TB, and "Shared Folders" only using 54 M.  This can't be correct.  I think for some reason, the "Shared Folder" data is being reported as "System" data.

    I updated the system with Power Pack 2, and the DEUTIL.DLL message doesn't come up anymore, but the "Shared Folder" problem is still there.

    Does anyone have a suggestion for remedy?
    Tuesday, July 7, 2009 7:19 PM

All replies

  • The data are definitely still there.  I've verified by connecting one of the drives from the WHS machine on another computer, and looked in the DE hidden folder.
    Tuesday, July 7, 2009 7:30 PM
  • Windows Home Server can't cope with having two Windows Home Server system disks connected. Unfortunately, this means that you'll probably need to reinstall again to correct the problem you're currently experiencing. Before you do that, though, you should check to see what each disk contains right now. Assuming the new disk is a valid Windows Home Server system disk, you can try removing the old disk and doing a server reinstallation. If you aren't given the reinstallation option, then try connecting that disk to another computer and deleting the system (smaller) partition, followed by another reinstallation.
    I'm not on the WHS team, I just post a lot. :)
    Tuesday, July 7, 2009 8:08 PM
    Moderator
  • Ken,
    I did a reinstall as you suggested.  No error messages this time.  It didn't work.  Shared folders are still showing as empty.  Any other suggestions?
    Tuesday, July 7, 2009 10:42 PM
  • I tried to remove one of the 250G drives.  WHS processed for over 2 hours, then came back with a data inconsistency - can't remove drive message (not the exact wording of the message).  The processing time is consistent with the amount of data I saw on this drive from the other computer, so WHS knows there are files there; question remains how do I get these files to show in the shared folders.
    Tuesday, July 7, 2009 11:58 PM
  • I tried to remove one of the 250G drives.  WHS processed for over 2 hours, then came back with a data inconsistency - can't remove drive message (not the exact wording of the message).  The processing time is consistent with the amount of data I saw on this drive from the other computer, so WHS knows there are files there; question remains how do I get these files to show in the shared folders.

    If that didn't work, the only other option is to recover the data manually.  Please see the FAQ post:  How to recover data after server failure for details on how to do that.
    Wednesday, July 8, 2009 2:52 AM
    Moderator