none
Error while trying to run project: Unable to start program. The request is not supported.

    Question

  • Hi, I'm having problems launching an application with VS2017 on Windows 10. Starting in Debug mode, a popup apperars with the message:

    Error while trying to run project: Unable to start program '<pathOfExe>'.
    The request is not supported.

    If I launch without debug, it runs. If I run it and then attach to the process, it attaches. If I run with administrative privileges, then it debugs (but I can't develop with administrative privileges). I'm owner of the folder where is source code and where project is built.

    It works like a charm on previous PC with Windows 7.

    Any idea?

    Friday, March 24, 2017 2:38 PM

All replies

  • Hi Simone Tognolo,

    (1)Please check "Use Managed Compatibility Mode" under Tools|->Options->Debugging->General.

    (2)Copy the project to a shared folder like from C disk drive to D disk drive folder.

    (3)Please clean and rebuild the whole solution before you debug it.

    (4)As you said that it works well if you run VS as the admin, at least, I know that sometimes some projects require the admin account. So please check that whether it also has the admin issue if you run other software in your windows.

    Thanks,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Sunday, March 26, 2017 4:27 AM
    Moderator
  • Hi Simone Tognolo,

    Any update for this issue?

    Would you please share us the latest information about this issue?

    Sincerely,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, April 3, 2017 7:11 AM
    Moderator
  • Hi Jack,

    thank you for the response. I've a project with C# and C++ code. If I check "Use Managed Compatibility Mode" I'm not able to debug C++ code. And if I also check "Enable native code debugging" in the StartUp Project, Visual Studio shows me again the popup with the message:

    Error while trying to run project: Unable to start program '<pathOfExe>'.
    The request is not supported.

    The only way to run everything in debug is to launch Visual Studio as Administrator. But I'm wondering why on a Windows 7 + VS2015 I doesn't need to start as Administrator.

    Thank you
    Simone

    Thursday, April 6, 2017 11:28 AM
  • Hi Simone,

    Whether the users in your two windows have the same Permission?

    If you save your app in the default folder:C:\Users\xxx\Documents\Visual Studio 2017\Projects, just copy it to D disk drive. How about the result?

    >>But I'm wondering why on a Windows 7 + VS2015 I doesn't need to start as Administrator.

    Actually I feel that it is related to your Windows user who have no enough permission in your windows 10. Of course, if possible, you could test it using the VS2017 in this windows 7, test it again. If it still works well, at least, we could know that it is not the project or VS2017 issue.

    Or you could add a new admin in your window 10, and then log in it using this new admin, test it again.

    If still no help, like my previous suggestion, whether other software still has this issue? Please close the third party tools or processes, test it again.

    If you get any latest information, please feel free to let me know. 

    Best Regards,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, April 7, 2017 5:26 AM
    Moderator
  • >>If you save your app in the default folder:C:\Users\xxx\Documents\Visual Studio 2017\Projects, just copy it to D disk drive. How about the result?

    Thank you @Jack

    That one solves my problem.

    Saturday, January 20, 2018 2:30 AM
  • I have similar problems.  I copied my project from C: to D:  and it worked for several iterations of build/run, but now the same problem is occuring.  In addition, I appear unable to write the .exe file so each execution causes a new build.  It really does feel like a permissions problem, but why would everything work for days, then suddenly fail? 

    Monday, September 10, 2018 8:57 PM