none
File Conflicts Among Other Things RRS feed

  • Question

  • New to the forum.  Hope this post is in the right spot.  Here goes and thanks in advance for any help.  I have a custom build which has been flawless for almost 3 years.
    Recently I noticed my issues after I attempted to remove a hard drive.  This might not be the only problem starter, but the only one I am aware of.  I followed the prompts.  I was told that I could not safely remove a drive.  I therefore disabled file duplication and tried again per the recommendation.  There was enough free space now for the attempt so I continued.  The green progress bar shot to about an eight of the way full, hung and then hours later a box pops up that said "failed".  Rebooted and tried again few times.  Same thing.  The backup service is not running.  Repair database fails every time.  All drives show healthy with the exception that one of them says "missing" every third boot or so.  I have file conflicts on and off.  When I try to simply delete the file, it will not delete (I/O error).  Here is the biggest issue.  I have quite a bit of data in my shared folders that I cannot open.  It is there, it takes up the appropriate amount of space, but they don’t open.  Pictures, music, PDF, etc.  I want to get the server back up to snuff, but at this point, priority one is getting this data un-corrupted.  Hopefully that is good info to start on.  Please let me know if I left something out or if there are questions.  Thanks.

     

    Thursday, February 18, 2010 6:41 PM

All replies

  • Disabling duplication may well kill your data in these folders totally, if the original was hold in the damaged disk.
    Did you attempt to physically disconnect the disk befoe removing it?

    Instead of repairing the backup database you can try to delete it completely:
    On the server open a command prompt.
    Enter following commands:
    net stop pdl
    net stop whsbackup
    d:
    cd  \folders\{00008086-058D-4C89-AB57-A7F909A47AB4}
    del *.*


    (You can also perform the deletion of all files in that folder from Windows Explorer after stopping the mentioned services, if you are not so sure about the command prompt.)
    After completing the deletion (ensure that no files did remain in the folder) restart either the services or the server.

    The data in your shared folders you cannot open any more are usually tombstones pointing to the files on the broken disk.
    Since you seem to have already done too much damage by disabling folder duplication I recommend to backup what you can still backup (check also the FAQ How to recover data after server failure) to an external drive or to a client  disk and perform a fresh installation after.

    Good luck
    Olaf
    Thursday, February 18, 2010 7:06 PM
    Moderator
  • In addition to what Olaf has said, any time you see file conflicts, it indicates a file system problem (of some sort, maybe hardware related, maybe not). One of your resolution steps should really always be checking all the drives in your server for errors .
    I'm not on the WHS team, I just post a lot. :)
    • Marked as answer by wheels6 Thursday, February 18, 2010 8:04 PM
    • Unmarked as answer by wheels6 Thursday, February 18, 2010 8:05 PM
    Thursday, February 18, 2010 7:12 PM
    Moderator
  • Sorry, thought mark as answer was the post button.  I did a check disk on all 4 drives using remote desktop and they checked out fine.  Thanks for the help!

    Thursday, February 18, 2010 8:14 PM
  • Olaf,
    Thank you very much for the help.  It sounds like deleting my database will not correct my file issues.  I can definitally pull the drives and put them into my other working machine to recover the data.  Your guide was very helpfull.  I will update you on my progress.


    Thank you.

    Thursday, February 18, 2010 8:52 PM