locked
WGA Fails after IE7 Uninstall RRS feed

  • Question

  • After uninstalling IE7 (caus of a script error on page popup when using Rhapsody and googletalk) and reverting back to 6 i have lost the ability to validate my copy of windows XP Pro.  WGA fails to complete every time.  I get 0x80080101 errors as well as 0x80080299 each time I try.  My OS was purhcased from Fry's,  so there is no reason to believe its bogus caus it has worked flawlessly up untill this.  I have been all over this help forum and nothing works.  I have run the legitcheck.exe to no avail and this is what MGADiag spits out.  Oh yeah, I have uninstalled IE6 for now as well.

    Any help would be greatly appreciated.

    Diagnostic Report (1.7.0012.0):
    -----------------------------------------
    WGA Data-->
    Validation Status: Genuine
    Detailed Status: N/A
    Windows Product Key: *****-*****-GP7M8-8K98D-FKXXM
    Windows Product Key Hash: tcZ6F+AdXEtmoAIAtUpV+2iRYtQ=
    Windows Product ID: 76487-018-7367921-22400
    Windows Product ID Type: 5
    Windows License Type: Retail
    Windows OS version: 5.1.2600.2.00010100.2.0.pro
    ID: 2bbfb2fb-d627-4999-ac68-b7173a0cedce
    Is Admin: Yes
    AutoDial:
    Registry: 0x0
    WGA Version: Registered, 1.7.36.0
    Signed By: Microsoft
    Product Name: N/A
    Architecture: N/A
    Build lab: N/A
    TTS Error: N/A
    Validation Diagnostic:
    Resolution Status: N/A

    Notifications Data-->
    Cached Result: N/A
    File Exists: Yes
    Version: 1.7.18.5
    WgaTray.exe Signed By: Microsoft
    WgaLogon.dll Signed By: Microsoft

    OGA Data-->
    Office Status: 100 Genuine
    OGA Version: Registered, 1.6.21.0
    Signed By: Microsoft
    Office Diagnostics: 70AFE6BE-116-800401f3_63BB5E84-365-800401f3_E2AD56EA-252-800401f3_16E0B333-57-800401f3_B4D0AA8B-910-800401f3

    Browser Data-->
    Proxy settings: N/A
    User Agent: Mozilla/4.0 (compatible; MSIE 7.0; Win32)
    Default Browser: C:\PROGRA~1\MOZILL~1\FIREFOX.exe
    Download signed ActiveX controls: Prompt
    Download unsigned ActiveX controls: Disabled
    Run ActiveX controls and plug-ins: Prompt
    Initialize and script ActiveX controls not marked as safe: Disabled
    Allow scripting of Internet Explorer Webbrowser control: Disabled
    Active scripting: Allowed
    Script ActiveX controls marked as safe for scripting: Prompt

    File Scan Data-->

    Other data-->
    Office Details:


    Sunday, May 13, 2007 6:07 PM

Answers

  • EHartz,

    Please try the solution previously posted by Darin Smith of Microsoft----the problem that he was responding to was very similar to the problem you posted.  Post back to tell us if it worked for you.

     

    This is an issue with your XML services on your computer. If you compare your diagnostic report with others on the forum, you will notice that you are missing a bunch of text at the bottom of your report. We call this the XML Blob. We have found that the 299 error in conjunction with the missing XML Blob means that either that the file msxml3.dll is unregistered (which means the registry key  ‘HKEY_CLASSES_ROOT\MSXML.DOMDocument’  is missing) or msxml3.dll is missing/corrupt.

     

    To fix your issue, follow the below steps:

     

    1) Click 'Start' button, then 'Run...'

    2) In the Run window, Type: regsvr32 msxml3.dll  <Click OK>
    (Note: This will register the msxml3.dll and the registry entry ‘HKEY_CLASSES_ROOT\MSXML.DOMDocument’ will be generated)

     

    If this does not work, the msxml3.dll may be missing or corrupt. Follow the below steps, in that case:

    1) Go to the 'Microsoft XML Parser (MSXML) 3.0 Service Pack 7 (SP7)' download page at  http://www.microsoft.com/downloads/details.aspx?FamilyID=28494391-052b-42ff-9674-f752bdca9582&DisplayLang=en

    2) From the files available, download “msxml3.msi”

    3) Double click the file and follow the steps to install.

    4) After the install is complete, click 'Start' button, then 'Run...'

    5) In the Run window, Type: regsvr32 msxml3.dll  <Click OK>

    Thank you,

    Darin Smith

    MGA Forum Program Manager

    --------------------------------------------------------
    All Users: Please go to http://forums.microsoft.com/Genuine/ShowPost.aspx?PostID=1255325&SiteID=25 before posting a question.

    Sunday, May 13, 2007 11:57 PM