locked
Another Variant of the "No Network Drivers" Issue RRS feed

  • Question

  • A virus corrupted my main desktop machine, and Windows 7 wouldn't come up.   (MSE cannot protect against the Windows 7 Antivirus 2012 malware; my wife keeps getting hit by it and this time it took out the machine.)  I confidently decided to restore from today's WHS backup.  I'd never done a firedrill restore on this Intel P67 machine, and sure enough the WHS restoration process couldn't find network drivers.  I plugged in my USB nic, kept around for emergencies, and fared no better.

    By an absolute miracle, System Restore from the Win 7 rescue facility worked, and I'm back up.  But it's time to get this issue resolved.

    I took the Windows Home Server Drivers for Restore folder and dumped it to a thumb drive.  I tried a practice restore, and directed the restore to the thumb drive.  Sure enough, it found some drivers.  Unfortunately, among those it installed, there were still no network drivers.   Would that be because that folder had Windows 7 x64 network drivers?

    I went to the Intel site, and of course the drivers are in an executable program rather than being directly extractable.  The program won't run on my Win 7 x64 machine, and I'm not sure I'd want it to.

    What's my best approach at this point?  I'm ready to temporarily put in another drive and install Vista 32, just to have the possibly-correct Windows Home Server Drivers for Restore folder.  Would that work?  Is there a better way to get myself proactively ready for a future restore?

    Advice welcome - I wasn't pleased to find this out the hard way, almost fatally.


    Art
    • Edited by Art Shapiro Tuesday, January 10, 2012 3:03 AM
    Tuesday, January 10, 2012 3:02 AM

Answers

  • I'll answer my own question for future reference. I downloaded the Vista 32 drivers for my particular motherboard (an Intel P67 ITX board) to a thumb drive; they came in an .exe file. While I now understand there's an extractor program available, I used WinZip to open the file. WinZip 14.5 would not correctly extract the numerous files that it showed, but WinZip 15.5 had no problems. Not knowing which I needed, I went into the PRO1000 folder and (perhaps unnecessarily) copied the NDIS5x, NDIS61, and NDIS62 to the root of the thumb drive.

    I started a restore, and provided the thumb drive when there was the given opportunity. The restoration process found the network drivers and I was then able to continue onward with the restore setup. I terminated it before actually starting to do anything, not wanting to overwrite my disk, but I'm now confident that I can restore to this machine.
    Art
    • Marked as answer by Art Shapiro Wednesday, January 11, 2012 12:48 AM
    Wednesday, January 11, 2012 12:48 AM