locked
Microsoft Dynamics CRM has encountered an error RRS feed

  • Question

  • We are currently getting the error "Microsoft Dynamics CRM has encountered an error" almost everytime we close or save on an entity (Account, Campaign, etc).  Below is the data that would be sent to Microsoft.  I was wondering if anyone is getting this message. 

    <CrmScriptErrorReport>

      <ReportVersion>1.0</ReportVersion>

      <ScriptErrorDetails>

                    <Message>Syntax error</Message>

                    <Line>4</Line>

                    <URL>/PaperHouseProductions&#47;sfa&#47;accts&#47;edit.aspx&#63;id&#61;&#123;0D157C9B-9AFC-DE11-9088-00155D6A0701&#125;</URL>

                    <PageURL>/PaperHouseProductions&#47;sfa&#47;accts&#47;edit.aspx&#63;id&#61;&#123;0D157C9B-9AFC-DE11-9088-00155D6A0701&#125;</PageURL>

                    <Function></Function>

                    <CallStack>

                    </CallStack>

      </ScriptErrorDetails>

      <ClientInformation>

                    <BrowserUserAgent>Mozilla&#47;4.0 &#40;compatible&#59; MSIE 6.0&#59; Windows NT 5.1&#59; SV1&#59; GTB6.3&#59; .NET CLR 1.1.4322&#59; .NET CLR 2.0.50727&#59; .NET CLR 3.0.4506.2152&#59; .NET CLR 3.5.30729&#41;</BrowserUserAgent>

                    <BrowserLanguage>en-us</BrowserLanguage>

                    <SystemLanguage>en-us</SystemLanguage>

                    <UserLanguage>en-us</UserLanguage>

                    <ScreenResolution>1440x900</ScreenResolution>

                    <ClientName>Outlook Desktop</ClientName>

      </ClientInformation>

      <ServerInformation>

        <OrgLanguage>1033</OrgLanguage>

        <OrgCulture>1033</OrgCulture>

        <UserLanguage>1033</UserLanguage>

        <UserCulture>1033</UserCulture>

        <OrgID>&#123;3BEF427E-16A6-4379-BAF9-41988C021747&#125;</OrgID>

        <UserID>&#123;C0BA080B-0AFB-DE11-BFB0-00155D6A0701&#125;</UserID>

        <CRMVersion>4.0.7333.2542</CRMVersion>

      </ServerInformation>

    </CrmScriptErrorReport>

    Thursday, January 14, 2010 2:49 PM

Answers

  • By the above it looks like you've customized the CRM Account entitiy, and the code that was written has a Syntax Error (as stated above). 
    Are you the CRM Administrator? If so, I would take a look at the CRM Account entitiy and see what you might have customized that would be causing this type of an issue. Chances are that you've written some JavaScript code that isn't running as it should.

    If you're not the CRM Administrator, I would contact that individual and have them look at the code they've customized for the CRM Account form, and the other entities that you receive this error on. Additionally, this *could* be caused if you're using McAffee antivirus on your client... I would disable the antivirus, and try the action again to see if your issue is resolved. 

    Please post back with more information.
    -Paul
    • Marked as answer by rubb0858 Thursday, January 14, 2010 5:39 PM
    • Unmarked as answer by rubb0858 Thursday, January 14, 2010 5:41 PM
    • Marked as answer by Donna EdwardsMVP Friday, January 15, 2010 6:36 PM
    Thursday, January 14, 2010 3:30 PM