locked
NTLDR missing on WHS Reinstall RRS feed

  • Question

  • I have a home-built server that had a 120-day eval copy of WHS. I purchased the full WHS and proceeded to "Reinstall". I walked away for a while (it took quite a long time), and when I returned, a file was listed in a pop-up box as missing. The choice was retry, skip, cancel - the normal routine. I chose retry, but WHS install warned that this might not be a good idea - scary, but no reason given. I did a "retry" and the install continued. But it hung at "51 minutes" for about 3 hours. I didn't know what to do, but the computer was unresponsive even to Ctrl-alt-del. Fianlly I had to hard-boot the *&($%# thing. On 2nd try, the "NTLDR is missing" error came up. Horrors.

    Here is what I tried:
    1) Repeatedly rebooted. (maybe I could get lucky...nope!)
    2) Checked the bios to see if what the HDD boot order was, and if they showed up. Yes, they were there, but they are identical 640 GB WD drives. Which one was the C:\?
    3) Tried to follow online tip of using USB drive to boot with replacement files. It wouldn't boot - does it have to be formatted like WHS or Server2003? Repeated with iso boot disk burned with the start up files. Still did not recognize it.
    4) Reversed the boot drive hard drive order - in case WHS was looking on the wrong drive for boot.ini or NTdetect or ntldr, etc. Now the WHS install disk would boot, but only offered a fresh install!!!!
    5) Reversed the drives back, and again with the NTLDR missing error!

    My system is:
    Intel Core 2 Duo E8600 3.33GHz
    2GB SDRAM DDR2 800
    2x 640GB WD SATA Hard drives - in IDE


    What can I do to not lose my shares and backups? Not to mention all my email, etc.?

    Help!
    Friday, March 20, 2009 6:01 AM

Answers

  • Hi,
    boneman2 said:

    What can I do to not lose my shares and backups? Not to mention all my email, etc.?

     

    this part is discussed in the FAQ How to recover data after server failure.

    NTLDR missing could have various reasons, i.e.:
    • a non matching volume written in the boot.ini
    • a corrupt or missing boot.ini
    • wrong disk boot sequence
    • a corrupt or missing ntldr file (hidden system file in the root of C:), if you boot from a Vista DVD and use the command prompt in the system repair options, dir /a c:\ should show this file (and the boot.ini)
    • a damaged harddisk or faulty RAM
    If the files are not on C:, but on another drive, the sequence in Bios may still be wrong.
    Best greetings from Germany
    Olaf
    Friday, March 20, 2009 9:07 AM
    Moderator