locked
Vail Remote Access Error '-21xxxx' error RRS feed

  • Question

  • Hey there ..

    I've used Home Server V1 for years, and recently began playing with VAIL. Very impressed to be sure. Specs = home grown, C2D w/3Gb RAM + a bunch of HDD's.

    However,  the one issue for me is remoe access, or an inability to remote control a machine from within the Vail "Remote Web Access" Page.

    Just to be clear:

    - I can remote to xxxx.homeserver.com from outside and inside the LAN, no problem

    - I can login to both without an issue, and stream music / video's without problem.

    - When I click on any PC or Server (the connect button), it displays a something similar to: "-2147024893" in an Internet explorer pop-up windows (ie 8 running under VISTA on a work PC), however this works from within my home network. Another user on my work network had the same issue, however we normally would RDP or use Remote Web Workplace to assist clients (I work for an IT Company) so I know it works normally.

    I've tried both Upnp and fixed IP on the home server, and I have tried manual port forwards on the router to the static IP (on the Linksys WRT610n), however no joy. In my mind it has something to do with port forwards or traveral of the Lan/Wan interface, but I am stumped.

    Any ideas? I've googled (and binged!) the ____ of this, but can't get any further. I have a snipit of the error, but can't find an (easy) way of including it in this post.

    Monday, October 11, 2010 7:34 AM

All replies

  • If you can connect to some specific PC on your home network from some PCs but not others, the issue is most likely on the client PC(s) you're trying to connect from.
    I'm not on the WHS team, I just post a lot. :)
    Monday, October 11, 2010 1:43 PM
    Moderator
  • No, everything is fine PC-PC (I have 6, all work between each other) on my Lan @ home. From work however, the couple of machines I have tried show the above "-2147024893" error in an IE dialogue box, yet streaming and other functions work as expected.

    It's just the remote web workplace stuff that seems a problem - can't control the home server remotely, and can't remote onto any of the PC's. WHS v1 worked without a problem.

    Any assistance is appreciated :)

    Tuesday, October 12, 2010 12:13 PM
  • You said:

    'When I click on any PC or Server (the connect button), it displays a something similar to: "-2147024893" in an Internet explorer pop-up windows (ie 8 running under VISTA on a work PC), however this works from within my home network.'

    Is that last phrase not correct? Does this not work from within your home network? If it does, your issue is unlikely to be with your server or your client computers. It may be that your workplace blocks this type of connection (though I don't see how; Vail doesn't use Remote Web Workplace, it uses the SSL RDP gateway that Windows Server 2008 R2 offers, which is just more https traffic), or it may be that your office computers are configured to prevent it, or it may be that your office computers don't have the correct remote desktop client installed (though that should be a different error, if that's the case).

    Whatever the specifics, submitting a bug report would be a good idea.


    I'm not on the WHS team, I just post a lot. :)
    Tuesday, October 12, 2010 12:57 PM
    Moderator
  • Thanks for the reply. It works at home, on the home network, just not from work trying to get into the home network remotely. Sorry if I wasn't clear.

    I'm going to try from another location, and additionally install Vail on a spare old drive (with all existing drives disconnected) and see if it works from vanilla. If still problematic will send in a bug report. Thanks for the help, I do appreciate it.

    Wednesday, October 13, 2010 9:32 AM
  • Hi all,

    I am facing the same issue:

    I log on to remote web access in my local network with a newly set up user. (recent fresh install of VAIL). When I try to say "connect" to the WHS it gives the -2147024893 error code.

    Let me know if you need some more details...

    Cheers,

    T.

    Wednesday, October 13, 2010 2:01 PM
  • yeah, I've been trying to fix it without going 'under the hood' ie, trying to get it to work as WHS Team intended. Has me stumped, and due to the error message is difficult to research.

    My plan was to try on a new install, however if yours is a fresh install, it doesn't give me much hope.

    If you do come up with a fix, pls post it here :)

    Friday, October 15, 2010 11:28 PM
  • ok, I've tried everything i can think of, time to blow it away and hope a new install will remove the issue. If only two of us have had this, or bothered to report it, I am guessing it is a one in a thousand type of problem.

    I'll report back either way.

     

    Friday, October 22, 2010 1:55 AM
  • ok, is now re-installed with no change in remote access behaviour. Can browse to xxxx.homeserver.com from another location, can login, can stream media etc. As soon as I click on the 'connect' button for any PC on the network, I get the error reported above. I'm wondering if it is a hardware issue, or a compatibility with one of the devices on my network.

    My Network consists of:

    Linksys WRT610N Router, connected to a Netgear DG834G ADSL modem set to bridge mode. All PC's are either directly connected the the WRT610n gigabit switch, with 2 connected via wireless. All are running Windows 7. Windows home server v1 worked flawlessly with no change to the network.

    Does anyone have any clue on how to diagnose something like this, or is anyone having a similar issue running similar hardware? I'm guessing I've hit a wall, but can't help but ask.

    Monday, October 25, 2010 7:40 AM
  • last post, I promise.

    Had success today. It turns out the three locations I was testing this from all are running similar network configurations, including a web filtering product called Webmarshal. (by M86 Security)

    As a last resort, I used my 3g connection on my phone to create a WiFi Access Point, and used the same notebook previously used to test on the work LAN to connect via the mobile wifi. It gave me a completely different error (which I can solve, permissions) but otherwise passed the traffic through and worked as it should.

    So, from a WHS perspective, all seems well. Thanks for your help regardless - the rest of this my network techs can figure out :)

    Tuesday, October 26, 2010 8:21 AM
  • Look up to my second post, where I said "It may be that your workplace blocks this type of connection …" :) I don't know anything about Webmarshal, but it's likely that if it's blocking your access to your home computers, it's on purpose.
    I'm not on the WHS team, I just post a lot. :)
    Tuesday, October 26, 2010 12:52 PM
    Moderator
  • ... it's worse than that. I tried it from a few of my clients networks, as well as my own (all SMB's - 25 users or less), and have discovered misconfigurations across all three. I just never put it together that the shared commonality was a single engineer and webmarshal. Our workplace doesn't block this on purpose, it was by error and is now working as it should (which is why i dismissed it initially).
    Wednesday, October 27, 2010 9:54 AM
  • OK, I now have this problem with WHS2011 RC. I have tried from locations in the US and UK so it is not the "common engineer" problem described above. Any ideas? Currently in the UK, so can not test locally in the US until next week.
    Saturday, February 12, 2011 4:46 PM
  • Same problem, WRT610N (the router is not working)...

    WHS2011RC give a problem with port 80 and 443 they are forwarded to the good IP and Upnp is enable, my V1 is working well

     

    Monday, February 14, 2011 3:37 AM
  • I have made some progress but not yet solved the problem. It appears to be related to my laptop (which is of course the machine I use for remote access!). The problem occurs on my local network and any location I have tested with my laptop from the Internet but have confirmed that from the same location other machines do not demonstrate the problem.

    I have WHS2011 RC connector on the laptop but it did not work prior to that. Disabling the firewall etc does not help the situation.

    Saturday, February 19, 2011 11:48 PM