locked
MPI is ignoring saved credentials - Part 2 RRS feed

  • Question

  • Dear Sirs,

    almost nine months have passed since, in Sept. 2017, I asked about the failure of using saved credentials with MS-MPI v8. Since then on, two new versions (that is 9.0 and 9.0.1) have been released but, quite amazing, and in spite of what the development staff promised, that issue seems to be still there, as I showed myself today: every time I start a MPI, it asks for credentials, despite they are saved on the usual registry key. MsMpiLaunchSvc is indeed a giant step in the development of MS-MPI,  but the problem seems to reduce its importance! Is there actually any hope to get rid of this annoying bug in a short future? Moreover, I think developers ought to also provide a basic script to set/reset the saved credentials, since some of the users of MPI are actually users and not developers themselves.

    Thanks in advance for the answer.


    • Edited by RotAnal2 Friday, June 1, 2018 4:49 PM
    Friday, June 1, 2018 4:42 PM

All replies

  • Actually, in Oct. 2017 a minor, working release of MPI (i.e. 8.1.1) has been released, but it has been not documented in the official Microsoft MPI Release Notes and, quite amazingly, its fix was NOT implemented in subsequent releases of MS-MPI (I myself tested the last one). I am wondering the reason why.

    EDIT: Anyway, the 8.1.1 is impossible to being used in my case because, when MyApp ends, MPI keeps hung and I have to manually quit the mpiexec job. I guess it has fixed in 9.x MPI releases, but I would like to get BOTH the above mentioned fixes (i.e. remembering credentials and quitting soonafter MyApp ends) in ONE release.





    • Edited by RotAnal2 Saturday, June 2, 2018 11:08 AM
    Friday, June 1, 2018 6:39 PM
  • Hi,

    Apologies that the save credentials option is not working. This is already fixed in the current master branch, and it will be available in the next MSMPI release (late Summer).
    Hope this works for you.

    Regards,
    Jithin

    Monday, June 4, 2018 9:53 PM
  • Dear Jithin,

    thanks for your reply. Waiting until september 2018 will be a long time for rather busy researchers! In fact, the software which I am using does not allow to set the password directly into MPI, but it wishes it already set. Therefore I have to use 8.1.1 version of MS-MPI, which, on the other hands has troubles in other regards, as I explained above.

    Anyway, we will try to survive.

    Thanks again for your development effort.

    Maurizio

    Thursday, June 7, 2018 11:51 AM
  • Just updating the thread that this fix is available in MSMPI v10.0
    https://docs.microsoft.com/en-us/message-passing-interface/microsoft-mpi

    Note: MSMPI is not open-source, please find us at https://github.com/Microsoft/Microsoft-MPI.

    Thanks,
    Jithin


    • Edited by JithinJos Tuesday, November 27, 2018 11:01 PM
    Friday, November 9, 2018 7:21 PM