locked
Factory reset of Acer H340 - "WHS initialization failed" during OOBE RRS feed

  • Question

  • I've spent some (ok, a lot of) time trying to test my Acer H340's reinstall capabilities.  As promised in this thread, the eventual goal is to come up with a reliable set of steps for tricky & undocumented scenarios like in-place upgrades of the system disk.  However, I haven't even gotten that far.  Here's what I know so far:

    * You need the original Acer DVD.  I tossed mine a long time ago, probably when I first unboxed it; I figure it's always best to download the latest & greatest straight from the hardware manufacturer's website anyway.  Bad plan -- Acer doesn't offer the ISO for download anywhere on their site.  Tried the official OEM image from MSDN, but it doesn't appear to support booting a remote machine via PXE.  Luckily there are torrents available of the original Acer disc.

    * As detailed here & elsewhere, Acer's instructions for initiating a PXE boot are wrong.  You have to push the reset button before turning it on & keep holding until you hear the fans spin down.

    * So long as you follow Foden's steps, Acer's recovery software will re-partition & re-image the system HDD just fine.  Both modes ("server recovery [recommended]" and "factory restore") seem ok, though I can't verify 100% correct behavior because...

    * Once the Acer-branded app exits and launches the MS Connector installer, things go downhill.  I click thru a couple steps of the wizard (autoupdate this client?  wake for backups?), then get to the screen titled "Your WHS needs to be initialized.  This process could take up to a few hours..."  It halts almost immediately with a vague error message: "WHS initialization failed.  Contact your OEM."  From what I've heard, talking to a knowledgeable human at Acer is a complete non-starter, plus I'm probably out of warranty by now.

    * According to Google I'm not the first one to get stuck at this point.  I've seen a large variety of solutions offered that supposedly worked for some people, but no luck for me yet.  Things I've tried:
    - unjoining from my corporate domain
    - running the Connector OOBE from another box whose OS is x86
    - running the Connector OOBE from a fresh vanilla XP SP3 environment (Virtual Windows XP, back on the main workstation)
    - putting the VM in a workgroup called "WORKGROUP" (vs "MSHOME")
    - using whatever Connector version that Acer's disc auto-launches
    - downloading a supposedly matching version of the Connector from http://aspirehome:55000
    - putting my workstation and the WHS on an isolated, switched network (no other machines, no router)
    - turning off Windows Firewall
    - toggling the "auto update this client" option in the Connector wizard
    - toggling the "server restore" vs "factory reset" option in the Acer wizard

    (All of these steps I took were cumulative.  If I get it to work, I might go back & narrow down the root cause later; first things first!)

    Running out of ideas.  All I can think of is putting the official OEM image of WHS on a bootable USB key as described at We Got Served.  This would have some added advantages:
    - speed
    - not having to spend time uninstalling all of Acer's ____ after future tests & upgrades

    However, I don't currently own a USB key that's big enough.  And since the H340 doesn't have a video port, getting it to work via trial & error could be a huge time sink unless the WGS instructions are 100% perfect out of the gate (not likely, given the quantity & quality of WHS documentation I've encountered so far!).

    Thoughts?  I've played with the WHS Toolkit, hoping it could diagnose my problems with the "initialization" step -- or at least capture some logs off the server.  Unfortunately it's been very unhelpful, just telling me things I consider obvious like "your Connector software does not match the server version."  Gee thanks, mind telling me what the two version #s are and where I can grab the right one?  Next step: engage Process Monitor to track down some trace info by brute force.

    The other thing that would help is if anyone knows the default admin credentials for the H340.  Given that, I could connect to its internal event log, browse its filesystem, Remote Desktop into it, etc.  Without it I can't even reach well-known UNC shares like \\aspirehome\software.  Thanks!
    Saturday, March 6, 2010 5:33 AM

All replies

  • Bump bump bump.
    Thursday, March 11, 2010 1:40 AM
  • "... default admin credentials ..."

    There are none. Until you go through OOBE (on a computer other than your server, given that you have an OEM server and therefore don't have any way to attach keyboard, mouse and video) the server has no Administrator password, but that also means that Remote Desktop isn't enabled.
    I'm not on the WHS team, I just post a lot. :)
    Thursday, March 11, 2010 1:53 AM
    Moderator
  • Have you tried turning off any anit-virus? I had to turn off my Norton anit-virus in order to reinitialize my Acer H340. With the anti-virus on I couldn't initialize the server. It just hung. After getting the H340 up and running I turned the anit-virus back on. It worked fine. After that I used the remote desktop to remove McAfee and some of the other nonstandard applications that Acer has attached. My H340 has be running fine ever since.

    Friday, March 12, 2010 5:31 PM
  • I don't use anti-virus.  There's the McAffee trial running on the WHS, but I can't do anything about that until I get admin access.

    I found where the installers were writing their logs, and also captured a full ProcMon log of the system during this process.  See: http://richardberg.net/bin/temp/whslogs.7z

    Pored over each one but didn't find any helpful clues.  Closest answer comes in WHSOOBE.log, in which we see that the client is trying to send command "i", repeatedly, only to eventually timeout (HRESULT = 0x8004245F, aka VDS_E_TIMEOUT -- I assume VDS is Virtual Disk Service or similar).  Subsequent attempts to run the OOBE fail quickly with a standard 0x80004005.  Unfortunately, nothing interesting shows up in ProcMon near those timestamps.

    Thursday, March 25, 2010 12:05 AM
  • WTF, why is half of my post hidden? (highlight to read)
    Thursday, March 25, 2010 12:20 AM
  • Fixed; you had managed to add some formatting...

    As for your issue, you could try another server recovery. Before doing so, though, I would recommend removing the drives from your server one at a time, connecting to another computer, and running chkdsk /r on each drive...


    I'm not on the WHS team, I just post a lot. :)
    Thursday, March 25, 2010 1:28 AM
    Moderator
  • I actually do a full server recovery (factory reset) after each attempt.  I copied the DVD contents to the HDD so it only takes about 10 minutes.

    Next steps I'm pondering:

    - attach to the COM server (CUIBC) manually and poke around from Powershell or similar

    - connect a USB keyboard to the Acer and see if I can reset the admin password blind [mimicking on another 2003 machine's console]

    - connect the almost-initialized WHS boot drive to another machine [w/ video output etc] and see if I can finish setup from there, then put it back

    Thursday, March 25, 2010 1:41 AM
  • Hi

    Where I can download the Acer H340 Server recovery image?  Please help with amessage to tcthien AT hotmail DOT com

    thanks

    Thursday, April 1, 2010 6:37 PM
  • Hi

    Where I can download the Acer H340 Server recovery image?  Please help with amessage to tcthien AT hotmail DOT com

    thanks

    To the best of my knowledge, you can't.  However, you should contact Acer for verification of that.
    Thursday, April 1, 2010 6:59 PM
    Moderator
  • Have you had any luck?  I have the exact same symptoms (Server initialization failed, contact OEM), and have tried many of the steps you describe.  Nothing has worked, and it's really starting to ____ me off.

    This all started when one of my HDDs died.  I pulled it, and tried to do a restore on the system.  It took me a long time to figure out how to do it properly, but finally I did.  Then it took me a while to get the connector reinstalled, and now when I get to initialization it just fails out.

    Please, if you found something or got it to work give me a hint.  I really don't feel like having to buy another license for WHS, and then hoping that it will work on my headless H340.

    Saturday, June 12, 2010 5:41 PM
  • Since the last time I posted here, I did another ~20 attempts, trying to remove every conceivable blocker.  No luck.

     

    Too many weekends down the drain.  I give up.  The hardware is perfect as far as I'm concerned, but the OEM software & support is just awful.  Current plan: install Vail on the darn thing.  Hopefully I can do it via USB + unattended install script (cfg.ini for WinPE), using VMWare to reproduce steps "blindly" as needed.  I also ordered a debug board just in case I need to peek at the display.

    Monday, July 5, 2010 5:23 AM