Send 486 Busy Here when in a call? RRS feed

  • Question

  • We have a setup which includes Office Communications Server, Mediation Server and SIP-PSTN media gateway.

    When an OC user is in a call and receives another call from the media gateway, caller hears ring back tone, not the busy tone. Is it possible to make the Office Communicator (or the server) to send a SIP “486 Busy Here” message when the user is in a call? This would indicate to the caller that the user is busy. Naturally per user configurable option is preferred.

    Wednesday, July 18, 2007 7:40 AM

All replies

  • Hi!


    I have the same problem. I think that Comunicator is only a multiline user. Is not possibile to configure it in mono-line. When an OC user is in a call and receives another call you can only accept the new call and put on-hold the first call or reject the new call.


    Another metod to reject the new call is: after you have received the first call, put in not disturb the comunicator.  But if you want "486 Busy Here" message your problem is not resolved because Comunicator send an "480 Temporalily Unavalaible".



    Wednesday, July 18, 2007 9:53 AM
  • Yes, this is a real problem.

    Most users would like to have further incoming calls blocked automatically (and a busy signal sent) when they are in a call. We weren't able to figure out how to configure OC/OCS in such a way that it would send a "486 Busy here" in any circumstances. It's a pretty bad thing if this isn't supported.

    The DND mode does work, but as you said, it's not a solution to this problem. It is way too uncomfortable to switch it on manually every time, and more importantly, the dialer gets a completely wrong response.
    Wednesday, July 25, 2007 6:49 AM
  • Is this intended behaviour or will this change before RTM? Is there a chance that advanced media gateways will work differently?
    Monday, July 30, 2007 9:37 AM
  • Hi There

    Can you update this thread? Have you implemented the RTM version and confirmed this is still an issue.?

    Wednesday, September 19, 2007 6:52 PM
  • Hi,

    I still have this problem. Cannot congifure the OC/OCS to send a 486 - Busy here message.

    I am using  an Enterprise Edition OCS Version: 3.0.6362.0 .

    Does anybody managed to solve this problem?

    Wednesday, April 9, 2008 4:03 PM
  • Any new info here, how can you configure communicator to send a busy tone to someone calling you when you´re already in a call?




    Monday, September 22, 2008 12:32 PM
  • this Q is still important at least for us.
    is there a solution?

    Monday, August 17, 2009 9:27 AM
  • Hi,
    If you do a SIP trace and have an OCS user call his/her own phone number - you will see a 486 busy. As far as I know, this is the only way to generate one of these in OCS.

    If you would like to prevent further calls from reaching you while on a call, you can set your status to "Do Not Disturb" once the call begins. That will send the call to VM.

    But for the original question "can you configure OCS to only accept 1 call - then send busy back to all additional calls" the answer is no.

    My guess is that it probably won't ever happen either. Don't forget - OCS is really looking to be a Unified Communications platform - a way to make sure people aren't wasting time trying to get ahold of eachother. Busy signals generally don't fit that mold - too little information for both the caller and callee. Sending the call to VM is probably the MS-supported option.

    But ultimately - yeah, it would be nice to have a "threshold" that would keep more calls from coming in & sending them to VM once the threshold was exceeded.


    Matt McGillen, PointBridge - https://blogs.pointbridge.com/Blogs/mcgillen_matt/default.aspx
    Tuesday, August 18, 2009 2:18 PM
  • I have tried a little different approach to getting the busy thing working...
    I created a small (Crappy, testing code - as you can see - not fit for production, but ment as a proof of concept code only!) routing script to make routing depending on the users presence (eg. Busy, on-the-phone)...

    The below script seems to work, or - rather - almost - depending on the strictRoute and proxyBydefault action...
    I actually managed to get it working - however - the UM stopped working then...
    I think my problem is that I do not have the time to gain the needed understanding...

    My hope was that it could get someone else started thinking and perhaps finish the script to make busy signal when busy work... the text searched for is the activity token that is in the XML of the state returned when a user is actually on the phone, and does not just have a scheduled meeting or such...


    <lc:requestFilter methodNames="INVITE"



                            domainSupported="true" />

    <lc:responseFilter reasonCodes="NONE" />

    <lc:proxyByDefault action="true" />




        // Build the user@host from the To: header.


        toUri = GetUri( sipRequest.To );

        toUserAtHost = Concatenate( GetUserName( toUri ), "@", GetHostName( toUri ) );



        // Now loop over all the endpoints for the To: user@host.


        anyEndpointBusy = false;

        foreach (dbEndpoint in QueryEndpoints( toUserAtHost, true )) {

            publication = QueryCategory(toUserAtHost, 2, "state", dbEndpoint.Instance);

            if (IndexOfString(publication, "on-the-phone") >= 0) {

                 anyEndpointBusy = true;





        // Respond busy if any endpoint was busy...


        if (anyEndpointBusy) {

            if (RequestTarget.Aor != "BENOTIFY") {

                Respond( 460, "Busy here" );

                Log( "Event", 1, "Busy responce given" );





    Friday, September 11, 2009 11:13 PM
  • Jan.. I think you break UM because you abort the call at the OCS level. When you activate DND and the user has UM, I figure the call would have to be refered to the UM system instead instead of sending a busy here.

    So, when you have anyEndPointBusy and the user is um enabled, you need to refer to extension@um, not respond with busy here and if the user doesn't have um you'd respond with busy here.
    Monday, October 19, 2009 12:24 PM