locked
Cannot update a user's DomainName in CRM 4.0 RRS feed

  • Question

  • Hi all,

    We've recently changed the domain for a few user's Active Directory accounts so they've effectively gone from DOM1\Jon.Evans to DOM2\Jon.Evans. I went into the user record to alter the DomainName but got the message:

    "You are attempting to create a user with a domain logon that is already used by another user. Select another domain logon and try again."

    When changing domain names, this sometimes happens and, if it does, I go into the database and manually update the DomainName field in SystemUserBase to the new domain name. Usually, this happens because someone's changed their name and has worked every time in the past. This is the first time that this has happened because of a domain change. Anyway, I changed the DomainName field but could still not log on.

    I reset the DomainName back to what it was originally and tried to create a new CRM account for the user. Again, I got the message above.

    Has anyone got any ideas about what I could try next?

    Wednesday, July 23, 2014 10:03 AM