none
Nokia Lumia 620

    Question

  • Hi

    Can't install Blank on the Lumia 620 as the store says it does not meet minimum requirements. Just wondered what requirement is missing?

    Tim

    Saturday, February 16, 2013 11:00 PM

Answers

  • Hi Tim,

    Thanks for your query, we pushed an update today that should make it available for all low memory devices such as the Lumia 620. Please try again and let us know if you have further questions.


    Thursday, February 21, 2013 11:57 PM
    Owner

All replies