locked
WHS Console Connection Problems RRS feed

  • Question

  • Hi guys,

    I have seen a few of these threads, but I haven't yet seen an answer that works.  So here is my problem:

    Fujitsu Homeserver running with all MS Updates, this has been running now for 12 months with the network configuration.  Since the last lot of updates from MS (I know that these installed as I was around when the server rebooted after installing), I can no longer access the homeserver via the console on a client computer.  I cannot connect via remote desktop with the following message:

    "Remote Desktop can't connect to the remote computer for one of these reasons:

    1) Remote access to the server is not enabled

    2) The remote computer is turned off

    3) The remote computer is not available on the network

    Make sure the remote computer is turned on and connected to the network, and that remote access is enabled."

    Firstly I can access the shares from all the computers in my house, I can access the website for the server via the homeserver.com address.

    This home server does not have a monitor output, so I cannot logon locally to the system.  I have tried to remote desktop to the server via a Windows XP and Windows 7 machine with no joy, I have also tried this through the web front end and get an error "Cannot connect to your home server. Check your network connection and make sure your home server is powered on."

    I cannot access via the console on a client machine, I cannot access the Admin$ share as I get an error saying the user name or password is incorrect.  This is not the case as I used the same password to join a new Netbook to the server yesterday.

    I can ping by name or ip and get a response as you would expect and have tried to remote desktop by name and IP with no avail.

    Can somebody please tell me what is happening or fix this please.  I don't want to have to re-install for an update to download a break this again.

    Thanks,

    Keith

    Monday, January 3, 2011 8:18 PM

All replies

  • Hi Keith,
    what is that for a font size? My bad eyes run away!

    Did you already try to either switch off or plug the power and then boot it up again? Sometimes I have seen normal Windows 2003 servers randomly not responding to Remote Desktop after applying patches and a reboot usually brought it back. Since the console relies on Remote Desktop, this could be the same issue.

    On the client, do you have and use for the connection an active Administrator account with the same password as the console password for WHS? If not, this will explain the access denied error for the Admin$ share. (Did you try the user name YOURSERVERNAME\Administrator instead of only Administrator?)

    Btw. - we all don't like Server reinstalls.

    Best greetings from Germany and a happy year 2011
    Olaf

    Monday, January 3, 2011 10:06 PM
    Moderator
  • Hi Olaf,

    Sorry not sure why the font changed like that.

    Yes I have ensured the server has rebooted several times, I also ensured that I tried to connect to the Admin$ share as the Home Server Administrator.

    However I have made some progress since my first post, after several reboots I can now access the Admin$ share from the new XP machine, although not RDP or Console access from the same client.  So I went ahead and installed Dameware remote desktop which needed access to the Admin$ share to copy across its client files.  Now with this tool I can logon to the server from the CTRL-ALT-DEL screen as the administrator.  But when I double click on the Console icon to launch I get this error:

    "HomeServerConsole.exe - Application error

    The application failed to initialize properly (0xc000007b). Click on OK to terminate the application."

    So it seems what ever the updates have changed, they seem to have caused an issue here.  Only problem is now that I can't see anyway around this error without a server reinstall.

    Unless you can through some light onto this?

    Thanks and Happy New Year to you also,

    Keith

    Monday, January 3, 2011 11:12 PM
  • Does anybody have any idea how to resolve this issue please?  If I need to re-install the server software will my current PC Backups be lost?  Is there anyway to ensure that they are retained as I need to get some info back that is held in a backup on the server?

    Keith

    Tuesday, January 4, 2011 8:48 PM
  • Is there still free disk space on drive C:?

    Either a full C: drive or a corrupt Administrator profile in Documents and Settings folder could cause failing logins. (dir \\server\c$ should show how much disk space is free if executed with WHS Administrator account)

    First check the logfile locations for WHS via C$ share and eventually delete those, which are obviously too big. You also can try to connect to C$ share and delete the Administrator subfolder from Documents and Settings as a last resort, as long as you didn't use your server as desktop replacement. I am not fully sure, if this has no side effects to Add-Ins or the console, but would be a method to try, if nothing works.

    Or assign another user account Administrator permissions via compmgmt.msc and try to login with that account. If this works, this would proof the profile corruption assumption.

    Best greetings from Germany
    Olaf

    Tuesday, January 4, 2011 10:33 PM
    Moderator