locked
Unable to connect the discovery service in plug-in registration tool RRS feed

  • Question

  • Dear All,

    I am writing the plugin in VPC. I am getting an error when i click connect in plug-in registration tool2.2 version even i entered the correct details. The error is " Unable to connect the Discovery service"

    Error Description

    Unhandled Exception: System.Net.WebException: Unable to connect to the remote server
       at System.Net.HttpWebRequest.GetRequestStream()
       at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
       at PluginRegistrationTool.CrmSdk.Discovery.CrmDiscoveryService.Execute(Request Request)
       at PluginRegistrationTool.CrmConnection.RetrieveOrganizations()
       at PluginRegistrationTool.ConnectionsForm.OpenConnection(CrmConnection con)
    Inner Exception: System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it 192.168.0.50:50
       at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
       at System.Net.Sockets.Socket.InternalConnect(EndPoint remoteEP)
       at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Int32 timeout, Exception& exception)

    I have entered all the correct values.Before that it was worked.Right now it is giving an error.

    Details

    Discovery Server:CRM-SRV-01

    port :50(this is localsdkport value in registry)

    Domain:Contoso

    username:administrator

     

    Please anybody gives the solution. I strucked this point.

    I am looking for your responses.

    Thanks & Regards,

    Sudhakar.

     


    Thanks & Regards, Sudhakar
    Monday, November 1, 2010 8:22 PM

Answers

  • which url you are using to access the crm in the browser?

    Use the same port.

    for e.g if you are using http://localhost then you try port 80

    if you are using http://localhost:5555 then try port 5555

     

    I hope it helps


    Amreek singh Senior CRM Consultant CDC Praxa Sydney, Australia http://mscrmshop.blogspot.com
    • Marked as answer by Jim Glass Jr Thursday, November 4, 2010 5:43 PM
    Tuesday, November 2, 2010 12:38 AM

All replies

  • The LocalSdkPort is stored in the registry as a DWORD which is hex; that translates to 80 in decimal, which is the standard http port.

    Try:

    • host: crm
    • port: 80

    The new CRM 4.0 VPC listens in on port 80, with host header "crm", as per your registry settings.


    --pogo (pat)
    Monday, November 1, 2010 10:14 PM
  • which url you are using to access the crm in the browser?

    Use the same port.

    for e.g if you are using http://localhost then you try port 80

    if you are using http://localhost:5555 then try port 5555

     

    I hope it helps


    Amreek singh Senior CRM Consultant CDC Praxa Sydney, Australia http://mscrmshop.blogspot.com
    • Marked as answer by Jim Glass Jr Thursday, November 4, 2010 5:43 PM
    Tuesday, November 2, 2010 12:38 AM