locked
Custom filtered views - not showing filtered results RRS feed

  • Question

  • Hello everybody,

    I am creating a custom views within an .htm page that is located inside the CRM folder. The page has the the proper structure. The only problem I have is that Dynamics CRM does not show me the filtered results but all existing entries (contacts).

    When using the advanced find tool the results are filtered. With the IE development tool I catch the INPUT values and copy them into the custom .htm page.

    When loading this page in an iFrame all contacts are shown but without any filter.

    Can anybody help my about this issue. Find below the html code:

    <html>
    
    
    
    <head>
    
    
    
    </head> 
    
    
    
    <body onload="resultRender.submit()">
    
    
    
            <FORM id=resultRender action="/AdvFind.aspx" method="post"> 
    
    
    
                <INPUT type="hidden" name="FetchXml" value='<fetch version="1.0" output-format="xml-platform" mapping="logical" distinct="false"><entity name="contact"><attribute name="fullname"/><attribute name="parentcustomerid"/><attribute name="telephone1"/><attribute name="emailaddress1"/><attribute name="contactid"/><order attribute="fullname" descending="false"/><filter type="and"><condition attribute="fidi_tipkontakta" operator="not-null"/></filter></entity></fetch>' /> 
    
    
    
                <INPUT type="hidden" name="LayoutXml" value='<grid name="resultset" object="2" jump="fullname" select="1" icon="1" preview="1"><row name="result" id="contactid"><cell name="fullname" width="300" /><cell name="emailaddress1" width="150" /><cell name="parentcustomerid" width="150" /><cell name="telephone1" width="125" /></row></grid>' /> 
    
    
    
                <INPUT type="hidden" name="EntityName" value="contact" /> 
    
    
    
                <INPUT type="hidden" name="DefaultAdvFindViewId" value="{00000000-0000-0000-00AA-000000666400}" /> 
    
    
    
                <INPUT type="hidden" name="ViewId" value="{00000000-0000-0000-00AA-000010001003}" /> 
    
    
    
                <INPUT type="hidden" name="ViewType" value="1039" /> 
    
    
    
                <INPUT type="hidden" name="SortCol" value="fullname" /> 
    
    
    
                <INPUT type="hidden" name="SortDescend" value="false" /> 
    
    
    
            </FORM>
    
    
    
        </body>
    
    
    
    </html> 
    
    
    
    

    Kind regards,
    petar

     

    • Edited by petar214 Tuesday, May 26, 2009 10:51 AM
    Tuesday, May 26, 2009 10:50 AM

Answers

  • The problem was with the missing Update roolup 3 for Dynamics CRM 4.0.
    After installing Update RollUp 3 my custom views are shown with the defined filters.

    Regards,
    Petar
    • Marked as answer by petar214 Tuesday, May 26, 2009 12:53 PM
    Tuesday, May 26, 2009 12:53 PM