locked
CRM 2011 Email Router receiving 61042 errors RRS feed

  • Question

  • We have CRM 2011 and Exchange 2010. I have set up the email router for outgoing messages. When I test the connection it works, but when I try to send an email I receive the following error. I have also added a new receiver connector to Exchange as internal and where the internal ip address is the machine that is running the email router.

    #61042 - An error occurred while processing the outgoing e-mail message with subject "Training-2 for Horowitz, Mark has been assigned." for SMTP: https://dev.crm.dynamics.com/crmNAorga7caa for delivery through server.guru.local. System.Net.Mail.SmtpException: The SMTP server requires a secure connection or the client was not authenticated. The server response was: 5.7.1 Client was not authenticated

       at System.Net.Mail.MailCommand.CheckResponse(SmtpStatusCode statusCode, String response)

       at System.Net.Mail.MailCommand.Send(SmtpConnection conn, Byte[] command, String from)

       at System.Net.Mail.SmtpTransport.SendMail(MailAddress sender, MailAddressCollection recipients, String deliveryNotify, SmtpFailedRecipientException& exception)

       at System.Net.Mail.SmtpClient.Send(MailMessage message)

       at Microsoft.Crm.Tools.Email.Providers.CrmPollingSendEmailProvider.Run()

    Thank you for the help!!

    Gary



    Thursday, February 21, 2013 5:25 PM

All replies

  • You must have your Receive connector setup to use SSL and you dont have this box checked on the Outgoing Profile

    Try creating a new connector with these steps.

    1. Open Exchange Management Console
    2. Expand Server configuration
    3. Click on Hub Transport
    4. In the Receive connector’s window pane Right click and select New Receive Connector
    5. Type CRM for the name and then click next
    6. Click next on the Local Network Settings page
    7. Add the IP address of the server that the E-mail Router is installed on and then click next
    8. Click New then Finish
    9. Right Click on the new CRM adapter and then select properties
    10. Go to the Permission Group tab
    11. Add Anonymous and Exchange Servers then click Apply
    12. Go to the Authentication tab
    13. Enable Externally Secured then click ok

    On the Outgoing profile in the Router, Use anonymous access

    Thursday, February 21, 2013 9:45 PM
  • Hi Chris,

    Thanks for the help!!

    I deleted my existing connector and and created a new using your instructions, restarted the email router, and I'm still getting the same errors. They are occuring for some email messages that were already trying to be sent. I'm not sure if that makes any difference.

    Gary


    • Edited by GaryMk Friday, February 22, 2013 9:06 PM
    Thursday, February 21, 2013 10:03 PM