locked
Re-Assign Order Issue RRS feed

  • Question

  • HI All,

     

    I am at an Order which is assigned to someone else. The CRM Admin User. 

    While i try to reassign it to me, it throws a "Invalid Argument" error on GUI. And the logs says that "There should be only one owner party for an activity".

    There is no activity assigned to that Order and the Order is created from a Quote which is created from a Project.

     

    What does this error mean and how do i solve it.

     

    Thanks in advance.

    Tuesday, January 25, 2011 4:05 PM

All replies

  • "A record was not created or updated because a duplicate of the current record already exists"

    the above issue is also thrown in the log along with the main issue.

    The Trace log also shows CRM.HasDuplicatesPlugin.Execute(...) ...

    why does it go for a duplicate check?

    checks against which data ?

    Tuesday, January 25, 2011 4:08 PM
  • I found Many History activity records related to that Order. Each activity belongs to CRM ADmin User but one.

    I deleted that activity but the same issue still remains.

    Tuesday, January 25, 2011 4:27 PM
  • Hi  Ustav,

    Check the following links,

    http://social.microsoft.com/Forums/en/crm/thread/a5535331-7b0f-4cd1-a5d5-ca2471eaaa46

    http://blogs.infinite-x.net/2009/10/28/duplicate-checking-process-flow-in-crm-4-0/

    regards,

    Tuesday, January 25, 2011 7:40 PM
  • Thanks for replying Ercan.

     

    But there is Duplicate Detection rule running on the Quotes, so I don't know how does that effect the issue which is coming.

    Let me know in case you need more information.

    Tuesday, January 25, 2011 10:18 PM
  • Your welcome Utsav,

    I hope you will solve the problem in a short time. You can try to turn off  Duplicate Detection Rules to see if it is give same error. Also you can take to trace of error.

    Regards,

    Wednesday, January 26, 2011 6:35 AM
  • Sorry Ercan I tend to eat my words when I write. =)

     

    There are NO duplicate detection running on Quotes which might be causing the issue I am facing the issue. Please let me know any other suggestions/solutions.

     

    Thanks,

    Utsav

    Monday, January 31, 2011 8:38 PM
  • This error message came up in the forums last week.  While searching through previous forum postings it seems most issues occurred due to corrupted activity data (most often from a prior conversion from CRM 3 to CRM 4).

    In all cases, the succesful options to move forward were:

    1. Find the offending data and remove it
    2. Turn off 'cascading options' in your entity customisations between Order (or whichever entity is causing issue) and Activity; re-assign the Order; turn 'cascading options' back on again

    Option (1) worked for last week's issue, but it requires some digging to locate the offending records.

    Option (2) is quicker, but will leave the Activity records assigned to the original owner.


    --pogo (pat)
    Monday, January 31, 2011 11:01 PM