locked
Error while creating user in CRM 2011 RRS feed

  • Question

  • Hello,

    I have windows 2000 AD, CRM 2011 on Server 2k8 and SQL Server 2k8.

    I have added many users from AD to CRM. but for two users, while adding to CRM, I get following error:

    Error

    An Error has occured.

    Try this action again. If the problem continues, check the Microsoft Dynamics CRM Community for solutions or contact your organization's Microsoft Dynamics CRM Administrator. Finally you can contact Microsoft Support.

    When I download the Log file it contains following:

    Unhandled Exception: System.ServiceModel.FaultException`1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]]: Server was unable to process request.Detail: 

    <OrganizationServiceFault xmlns:i="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://schemas.microsoft.com/xrm/2011/Contracts">

      <ErrorCode>-2147016649</ErrorCode>

      <ErrorDetails xmlns:d2p1="http://schemas.datacontract.org/2004/07/System.Collections.Generic" />

      <Message>Server was unable to process request.</Message>

      <Timestamp>2012-01-20T19:26:17.2573666Z</Timestamp>

      <InnerFault i:nil="true" />

      <TraceText i:nil="true" />

    </OrganizationServiceFault>

    Please help.

    Friday, January 20, 2012 7:29 PM

Answers

  • Sorry for not replying guys.

    Thanks for the answers.

    Actually, I solved the problem by choosing "Administrative" Role when adding user. Then I saved the user, and then changed the Access to "Read-Write", then the users were added.

    I did not require enable tracing.

    • Proposed as answer by Philippe LEAL Tuesday, January 24, 2012 7:44 PM
    • Marked as answer by kaustubhg123 Thursday, January 26, 2012 12:22 PM
    Tuesday, January 24, 2012 4:41 AM

All replies

  • HI, that is a very generic error, I recommend you to enable the tracing and checking the trace files for more detailed information about the error. If you don’t know how to enable the trace you can download the crmdiag2011 from codeplex athttp://crmdiagtool2011.codeplex.com/
    Regards,
    Damian Sinay
    Sunday, January 22, 2012 5:46 AM
  • Also you might consider is to turn on the dev errors for more details of error

    http://rostacik.net/2011/07/07/how-to-turn-on-developer-errors-in-microsoft-crm-2011-aka-titan-or-5-0/

    dkay

    Sunday, January 22, 2012 7:07 AM
  • notice you can also turn on the Dev errors using the same crmdiagtool2011 y referred above.
    Regards,
    Damian Sinay
    Sunday, January 22, 2012 7:29 AM
  • Hi

    Did this help?

    Please make sure to mark as answer to the response that helped you get through. This will help others with similar problem identify the answer and also close this thread as resolved.

    Thanks

    Dkay

    Monday, January 23, 2012 12:47 PM
  • Sorry for not replying guys.

    Thanks for the answers.

    Actually, I solved the problem by choosing "Administrative" Role when adding user. Then I saved the user, and then changed the Access to "Read-Write", then the users were added.

    I did not require enable tracing.

    • Proposed as answer by Philippe LEAL Tuesday, January 24, 2012 7:44 PM
    • Marked as answer by kaustubhg123 Thursday, January 26, 2012 12:22 PM
    Tuesday, January 24, 2012 4:41 AM