How to set default phone number for a contact? RRS feed

  • Question

  • One of the contacts in my address book (not in the corp address book) consistently shows the mobile number as the first number in the list.  However, I want to call the home phone # by default.  I’ve been unable to find a way to do this.


    Things that I have tried:

    (1)    Removing the contact and re-adding the contact from OC2007.

    (2)    Setting the home phone to show as the first phone in the business card (outlook contact view).

    (3)    Setting the home phone to show as the first phone listed in the outlook contact view (the four grey buttons next to the phone number entry boxes, that say stuff like "Home...", "Work...", etc.

    (4)    Deleting the mobile number (worked).

    (5)    Adding back the mobile number (reverted to mobile as default phone).

    (6)    Removing the contact and re-adding the contact from OC2007 again after all the above.


    However, none of these works.  I simply cannot find the way to indicate that this is the “default” phone.  This is a problem because the tanjay phone auto-dials when I accidentally click the name, and it’s constantly ringing up small cell phone charges.  This is also a problem when I try to start a phone conversation and it dials the mobile instead of home (either Tanjay or OC2007).


    Can you please help me to understand how to set the home phone as the preferred phone number?


    Thank you,


    Henry Gabryjelski

    Techology Specialist



    P.S. – If it’s just a hard-coded ordering of “Work, Cell, Home”, please let me know that also (even though it’d be unfortunate).

    Tuesday, June 3, 2008 5:55 PM

All replies


    My communicator remembers the number I last dialed for the contact and lists that number as the default afterwards

    You should try it


    Tuesday, June 10, 2008 9:40 PM
  • I have a similar situation.  I have a user that has a tanjay device.  Everytime he taps a contact in the contact list it attempts to dial either the contact's home, mobile, or work number (Depending on what the contact information that particualar contact has).  Currently, all of the contacts this user has are internal contacts that have communicator and tanjay devices.  On this user's PC the default call method is the last dialed number for a contact... currently they are all defaulted to communicator calls.  Is there any way that you can adjust the default number to be called from the tanjay.  Other users, including my self, don't have this issue with the same contacts. (All phone information for these contacts are stored in active directory)  Also, I logged this user into another tanjay device and the issue followed the user.


    Anyone have any thoughts?






    Friday, June 13, 2008 1:18 PM
  • I have a similar issue.  There are a couple of contacts on my Wife's Blackjack II that always come up defaulted to "txt" when she would prefer them defaulted to "m".  If anybody has any clues on how to change this. please post here.
    Friday, August 1, 2008 11:31 PM
  • That behavior is not configurable as far as I know, the client automatically selects devices in a predetermined order depending on their existence.


    If a contact has no phone numbers associated with it, then a Communicator Call will be the default (and only) choice.  If there re phone numbers, then it will select with the Work phone number unless that doesn't exist then it will show the Cell or Home phone number, depending on what is configured.  If multiple numbers are set it will always start with the Work Number.


    Once a contact is has been dialed, OC will default to the most recently used choice in the list.


    Regarding the Blackjack, that question should be posted in a forum for Windows Mobile devices.  That said, I have the i607 and haven't figured out how WM6 decides to select an option; its seems to change randomly.


    Sunday, August 3, 2008 1:46 PM
  • Thanks, Jeff.  I figured out the "most recently used choice" thing after I posted here.  My wife is visually impaired and she is likely to never want to send a text message so it would be really useful if I could find a way to make that choice disappear forever on her Blackjack II.

    I know there is a windows mobile forum (http://forums.microsoft.com/WindowsMobile/) even though  it doesn't seem to be listed on the forums home page as far as I could tell but this was the place where my search found the issue I  had so here was where I posted it (and in the Brighthand.com forum for Blackjack and Blackjack II - http://forum.brighthand.com/forumdisplay.php?f=1308).  I don't know why it got started here, but maybe somebody with admin priviledges should move it to an appropriate place in the WindowsMobile forum?

    Thanks again for your help!

    Sunday, August 3, 2008 3:57 PM