locked
ADSL router problems RRS feed

  • Question

  • I can't see my WHS webpage in remote access and think it might be due to my TP-Link 8840 ADSL2+ router.  So far I haven't been able to configure the router.  When I try to configure it tells me it doesn't support UPnP, even though it passes the separate Microsoft UPnP test.  I've forwarded all the ports and ShieldsUP reports 80 and 443 are open, and 4125 is closed, so the UPnP issue shouldn't matter?  (Port Detective tells me ports 80 and 443 are "blocked" - do I have a problem here?)

     

    When I set up my domain and click on the link to the webpage once it's set up, I get this logon message "The server myname.homeserver.com at DSL Router requires a username and password".  But the username/pawword it wants is the router logon details, not WHS (leastways my router config page opens when I enter the router logon details, and nothing happens with my WHS logon details).  Does anyone know a way past this?

     

    Is there an issue using an ADSL router with WHS? I think the recommended routers mostly look like non-ADSL.  I have my router going to a gigabit switch and my server and client PCs hang off that.  I tried hooking my PCs straight off the router, but it wasn't any better.

     

    This is driving me mad.  Any advice could save a lot of hair...

    Saturday, March 15, 2008 7:19 AM

All replies

  • It sounds as though you have 'remote access' enabled on the router, so port 80 is going straight to it's log-in page. Does it either have a facility to disable the remote access, or forward port 80 to the WHS.

    There is no reason as all why you shouldn't be able to use an ADSL router, some of my customers are using them along with WHS, with no problems whatsoever.

     

    Colin

     

    Saturday, March 15, 2008 6:19 PM
  • Thanks Colin.  What you suggest does seem to fit the problem, but I can't find settings that solve it.  The TD8840 has a setup table for LAN and WAN access to the router, but HTTP was enabled for LAN and disabled for WAN.  ICMP was the only option where WAN access was enabled, and I turned that off.  No change... I also disabled HTTP for LAN, which wasn't the best idea... I'll be fixing that next.

     

    I don't know if this is relevant, but when I forward port 80 to the server, I get a message from the router saying it is moving port 80 to 8080.  Someone told me previously that would be for internal LAN access to the router, so should be OK.

     

    I'm held back by complete router ignorance, and utterly useless support from TP-Link.

     

    I don't suppose you know of a 4 port ADSL2+ router that definitely works with WHS?  I'm over TP-Link.  I actually want an ADSL2+ router with gigabit ethernet but they don't seem to exist?

     

    Do you know if any of your customers are doing the same as me - running a gigabit switch off the router?

    Saturday, March 15, 2008 10:58 PM
  • Hi,

    Found this FAQ, which appears to address your circumstances.

    Is it possible to try running the WHS directly off the router, that way, you limit the setup hassle. If so, and that will work with the FAQ setup, then it should be possible to then moveit back to the switch.

    I don't know of any combined modem/routers on gigabit, my installations have, to date, been separate boxes.A modem into a router; usually just now, the D-Link DIR655. (Most customers already had a modem with their setups, so found this was an easier option).

    There have been a few problems with your router/switch comination mentioned through the forum, maybe a search on those might help as well.

     

    Colin

     

     

    Sunday, March 16, 2008 4:42 PM
  • Thanks Colin

     

    Sorry I've been off the air for a few days.  I had a look at that FAQ and it looks like I was doing the right thing.  I did try running the router directly to the server but I got the same results.  Maybe I should try again and give it more time - I've noticed it sometimes takes a while for the server to pick up on changes in the network.

     

    I'll keep searching as you suggest.

     

    Mike

     

    Tuesday, March 25, 2008 1:03 PM