Unable to connect to a Windows Home Server RRS feed

  • Question

  • I have read a lot of similar posts about this, but they never seem to apply to my issue.

    I can no longer connect to the WHS console with the connector software nor Remote Desktop.  Also, the shares are not accessible either. I have tried connecting to it with the computer managment utility to look at event logs and that cannot connect. When running the discovery utility it cannot locate the server either.  The only thing that does work is that I can ping the server by name and IP. 

    This in an Acer model so I have no monitor.  I get the feeling that it has an error message on it waiting for someone to hit OK.

    This has happened before and the only thing I could do is rebuild the server with the Acer Recovery CD's.

    Any ideas?



    Thursday, November 12, 2009 8:06 PM

All replies

  • I assume that you have re-booted?
    Thursday, November 12, 2009 8:50 PM
  • about 3-4 times now.
    Thursday, November 12, 2009 9:08 PM
  • Hmm. So you can ping it, so it has not locked up in the BIOS and must have got to WHS. I don't know anything about the Acer model as I built my own incorporating an old VGA card as I was sure I would need it at some point and indeed I have. Can you put a card in the Acer and see what is going on?

    Thursday, November 12, 2009 9:22 PM
  • I have been looking to see, but no hits yet.  I would need to buy one and I don't know if the BIOS would support it.  It does have a PCI-E card slot in it.
    Thursday, November 12, 2009 9:27 PM
  • Any BIOS should be able to support a display card at at least VGA resolution which should be fine to see what's going on. The cheapest of cards should not cost too much. Other than doing that, you would just be guessing!

    Interesting though that a server rebuild got you over the problem previously, although this seems as though it is a re-occurring problem. Is the server still under warranty? That's probably not a route you want to go down if you can solve the problem yourself.

    Thursday, November 12, 2009 9:49 PM
  • It is under warranty, but it is not an issue for Acer I think. This feels like a software issue. If memory serves correctly it is always after Patch Tuesday.

    I got the server back in September and this is the second time this has happened. 

    I am tempted to buy a video card for it to see what is going on.  I do not want to rebuild this thing every month!  However, there has to be something else that is causing this.
    Thursday, November 12, 2009 10:40 PM
  • Acer, I believe sold you a system not just a box on which you installed some software. Their warranty should cover the "WHSystem" they sold!! However I too would be temped to try to fix it myself.
    Thursday, November 12, 2009 10:52 PM
  • I agree. I was hoping that this may be a common problem with a simple solution. I would rather fix it my self than deal with Acer. If I can't get a response here about what could be causing it. I will give them a try. I have read some posts here that their customer service is terrible.
    Friday, November 13, 2009 12:07 AM
  • Would Remote Desktop work, if you try to connect via IP address?

    Are you sure, that you rebooted the server? It could be, that the power button is configured to send the server to Hibernate instead. (Cannot tell the default behavior for the Acer, but have seen this on other OEM machine.) Eventually I would try to simulate a hard power outage in this case (if I am sure, that my data backup is up to date).
    You could also pull each disk and check them after attaching them to a client PC (i.e. using an USB to SATA connector cable).
    In the FAQ How to recover data after server failure you can read, how to access the data stored in the shared folders, if this should be necessary.

    Best greetings from Germany
    Friday, November 13, 2009 8:12 AM
  • Hi Olaf,

    The Remote Desktop connection does not work either.  I did do a hard reset of the server by shutting it down and pulling the power cable from the back and then plugging it back in and powering it back up.  I got the same results.

    I do have solid backups of my data. I am not worried about any data loss. I know I can rebuild the server, but since this is a reoccuring problem, I am ready to invest the time to solving it so I do not have to continuously rebuild the server.

    As a recap:

    I am able to ping the server IP address.

    I am unable to connect to the console with the Home Server Connector and RDP.  My shares are NOT accessible.  I cannot connect to the computer with event viewer or any other remote tool.
    Friday, November 13, 2009 4:15 PM

    I have been working with this more today and I am getting into the server over RDP, but only for a short while.

    The server boots up and I start a ping so I know when it is available.
    I immediately launch RDP and can get into the server, after about 30 seconds RDP stops working.  The server still responds to pings though.

    Could this be a firewall issue?

    I need to figure out how to get it in and disable whatever is going on very quickly.
    Friday, November 13, 2009 7:05 PM
  • These are the moments, in which I really hate the regulation, that WHS OEM models have to be delivered without display output.
    Since you have not even enough time to check any configuration, before the connection drops, it could indeed some software blocking the connection.
    Either something, which is crashing, or some security software on the server. I remember people having issues with the McAfee Suite after upgrading it to full version and lost the WHS connectivity that way. Also resetting the Windows Firewall to the default settings will block the connection.
    For the Windows Firewall you could try to open a cmd prompt and enter the command
    net stop sharedaccess

    Not sure, which command would be needed for other security suites, maybe it is documented somewhere.

    Best greetings from Germany
    Friday, November 13, 2009 8:06 PM
  • I removed McAfee thatc ame with it since it was only a trial version.  I installed a copy of CA Anti-Virus that I get for  free through my ISP.  I was able to get in and stop the service, but it still lost the connection.  I will try Windows Firewall next.  Thanks for the quick command.  Fingers crossed.

    Friday, November 13, 2009 8:31 PM
  • I was feeling really good about shutting the firewall down, but it dropped access again.  Are there any other services that could be stopping remote access altogether?
    Friday, November 13, 2009 8:48 PM
  • I have now gone in and removed patch KB969947.  It was the most current patch on the system and that did not resolve it either.
    Friday, November 13, 2009 11:14 PM
  • Time for a VGA card?
    Friday, November 13, 2009 11:58 PM
  • Do they make a VGA card that will fit that slot?

    I have removed every patch from the latest Patch Tuesday and it still does not work right.
    Saturday, November 14, 2009 5:01 AM
  • I found a USB VGA port adapter. With some careful adjustments, I now have direct console access.  After about the same amount of time the whole system locks up and I can't navigate with direct console either. I can move some windows around, but the start button is unresponsive and when I try to close an open window it becomes unresponsive. Seeing how it is an OS issue and there is nothing in the event logs that would give me any idea what is causing the lock up, I am going to rebuild the server again. I don;t see how I can troubleshoot this in 45 second intervals. Eventually, the hardware will fail and then I have a bigger problem.
    Saturday, November 14, 2009 2:37 PM
  • Do they make a VGA card that will fit that slot?

    I have removed every patch from the latest Patch Tuesday and it still does not work right.
    I think it will depend on what type of PCI-E slot you have on the motherboard. Most current cards seem to be PCI-E x16 see here for a cheap option ($10) if you are in the US:


    Saturday, November 14, 2009 2:45 PM
  • I don't know if that will fit.  This is not a standard size PCI slot.  I fond this in my searches yesterday.


    On page 50 it has the specs of the motherboard.  The USB option was cool, but it only worked in Windows.
    Saturday, November 14, 2009 3:30 PM
  • Is there enough time to access the event viewer in Control Panel/Administrative Tools and see, if there are related errors listed pointing to some service or application?
    Best greetings from Germany
    Saturday, November 14, 2009 10:30 PM