locked
Cannot Add new Organizaton to CRM 4.0 RRS feed

  • Question

  • I received the following error attempting to create a new organization in CRM 4.0. The first time I tried I used an account that didn't have AD rights, I tried again with the correct account and now this is what I am getting? Anyone have any ideas?

     

    11:43:37|   Info| Setting the base currency of the organization...
    11:43:37|   Info| Create Organization Reports...
    11:43:38|  Error| Create new Organization (Name=HCBS, Id=c69d9e53-b0be-e011-b3cb-0019b9ee141f) failed with Exception:
    System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.DirectoryServices.DirectoryServicesCOMException (0x800700B7): Cannot create a file when that file already exists. (Exception from HRESULT: 0x800700B7)
       --- End of inner exception stack trace ---
       at System.DirectoryServices.DirectoryEntry.Invoke(String methodName, Object[] args)
       at Microsoft.Crm.Setup.Server.Utility.IIsUtility.StartWebSite(String metabasePath, String machineName)
       at Microsoft.Crm.Setup.Server.Utility.ReportsUtility.ConfigureReports(Uri reportingUrl, String organizationName, Boolean grantNetworkService)
       at Microsoft.Crm.Setup.Server.Utility.ReportsUtility.CreateReports(String organizationName, Boolean grantNetworkService, String reportingUrl, String reportFilesLocation, Int32 languageCode)

    Thursday, August 4, 2011 4:20 PM

All replies

  • Hi,

    When you create a new org the deployment manager will create a database called orgname_MSCRM. It seems like that the Organization name that you are speicifying has database files (ldf & mdf files) already exsist in the directory, try choose other name or add _ in organizaiton name or delete exsisting files.


    Jehanzeb Javeed

    http://worldofdynamics.blogspot.com
    Linked-In Profile |CodePlex Profile

    If you find this post helpful then please "Vote as Helpful" and "Mark As Answer".
    Thursday, August 4, 2011 5:21 PM
  • As the error is a DirectoryServicesCOMException, I don't think the problem would be with creating database files (as that'd give a SQL error). As the step before the error refers to creating reports, I'd check your report server to see if there's already a folder with the name HCBS_MSCRM - note that this may be hidden in Report Manager 
    Microsoft CRM MVP - http://mscrmuk.blogspot.com  http://www.excitation.co.uk
    Thursday, August 4, 2011 5:46 PM
    Moderator
  • Jehanzeb

    When it first happened the first thing I checked was to see if a DB has been created. I verified that it wasn't and I also checked to see if any log files were created. Nothing.

    David

    I checked both reporting services URL's and do not see any folders related to the organizaiton name. Unless as you suggested its hidden, if so where do I unhide this?

    Update: I tried to set up a new orgaiztion, new name using the correct account and received the same error?

    Friday, August 5, 2011 12:11 PM
  • Hi,

    I suggested database files because while adding a new organization setup creates a new files for the database and does not creates any file into the reporting services. Reporting services contins all reports files rdl xml into the database table.

    Update: If you have tried with a different organization name (unless was created before in the deployment) then there should be no chance of conflict in SQL Server Reporting services directories and SQL Server Database files.


    Jehanzeb Javeed

    http://worldofdynamics.blogspot.com
    Linked-In Profile |CodePlex Profile

    If you find this post helpful then please "Vote as Helpful" and "Mark As Answer".






    • Edited by Jehanzeb.Javeed Friday, August 5, 2011 12:39 PM Add Update Notes
    Friday, August 5, 2011 12:35 PM
  • Where else can I check, I looked for log files and I verified there were no databases created. Given I tried an entirely new organization I am not sure what's left in order to troubleshoot the issue.
    Friday, August 5, 2011 1:04 PM