locked
Exception during preview. failed to create the providor RRS feed

  • Question

  • Hi

    My laptop has windows 7 ultimate installed and I have a sync setup between a folder on my laptop and a folder on my widows home server.

    This has worked great since installation. Over the last week I have been getting the same error message (see above). I've uninstalled and reinstalled sync-toy and tried setting up new folders. The end result is the above message whatever I do.

    Has anyone any suggestions please?

    Thanks

    Tom

    Tuesday, July 6, 2010 7:20 PM

Answers

  • THX "Repair Microsoft Sync Framework 2.0 Provider Services (x86) ENU" was my friend

    now it works :)

    Monday, August 9, 2010 8:17 PM

All replies

  • Exactly the same here, Win 7 Pro Enterprise, sync from local folder to a network folder, no Idea why...
    Monday, July 12, 2010 12:32 PM
  • My wife has win 7 pro and she can sync no problem to the same folder.
    Monday, July 12, 2010 5:49 PM
  • OK, I now deinstalled SyncToy, deinstalled the Microsoft Sync Frameworks, deinstalled recent .NET related Update packs that had been installed automatically by MS Update, reinstalled MS .NET 3.5 SP1, reinstalled SyncToy, restarted 2 or three times because of automatic .NET related Updates, and now it works, with all settings still there.

    Hope it works for you as well.

    • Proposed as answer by glientsc Thursday, July 15, 2010 3:25 PM
    Thursday, July 15, 2010 3:25 PM
  • THX "Repair Microsoft Sync Framework 2.0 Provider Services (x86) ENU" was my friend

    now it works :)

    Monday, August 9, 2010 8:17 PM
  • This alone did not work for me. I also had to reinstall/repair other packages from http://www.microsoft.com/downloads/en/details.aspx?FamilyID=109db36e-cdd0-4514-9fb5-b77d9cea37f6

    Possibly "Synchronization-v2.0-x86-ENU.msi" was sufficient.
    • Proposed as answer by Bitjuggler Saturday, March 26, 2011 1:13 PM
    Friday, September 10, 2010 11:28 AM
  • Thanks for the help!

    In my case it turned out that DatabaseProviders-v3.0-x86-ENU.msi was not installed, so when I executed the file, it installed the database providers. I repaired the other two (ProviderServices-v2.0-x86-ENU.msi, Synchronization-v2.0-x86-ENU.msi), then it worked again... strange, because it was working before, so why is there a new dependency on database providers?

    Saturday, March 26, 2011 1:17 PM
  • I faced the same problem and my desktop has Windows XP. I just retored the computer to a previous date when the SynToy was found to be working fine and everything became normal.
    Wednesday, February 12, 2014 2:42 AM