locked
ESata drive comes up unallocated after reboot RRS feed

  • Question

  • I have a 500GB WD mybook External hooked up to my WHS. I formatted it NTFS and made it part of the back up disk through the WHS wizard. After running a backup i restarted the machine. When it came back up the drive was no longer visable in My Computer so i went into the WHS console and it is now showing it not added to anything and comes up as unallocated in the disk manager. I have done this about 3-4 times to test it. It seems like WHS deletes the partition upon reboot. Has this happened to anyone else? it is showing the drive in the console as a SATA WD SCSI Internal but it is hooked up via ESATA.
    • Changed type AWithers04 Wednesday, March 11, 2009 1:47 AM
    Wednesday, March 11, 2009 1:25 AM

All replies

  • Could you try connecting the drive to some other computer to see what's actually on it? The server backup feature in Windows Home Server allows you to remove a backup drive temporarily or permanently; it sounds like your drive is being removed temporarily when you restart. I haven't noticed this behavior personally, but I use a different backup methodology for my server.

    I'm not on the WHS team, I just post a lot. :)
    Wednesday, March 11, 2009 2:47 PM
    Moderator
  • I had been putting off posting my similar situation to the forum, as I wasnt sure it was me who was doing something wrong.

    I have an HP EX470 with a 500 GB drive where the operating system resides and 3 - 1 TB drives.

    I have been getting closer to running out of space so I bought an Addonics 4 port multiplier to connect via ESata the WHS to a 4 drive backplane. The backplane has one 1 TB drive and one 500 gb drive. I have tested the new drives, formatted them on other machines, connected them one at a time via USB or ESata and the drives are all working properly.

    But I have the same problem as stated by AWither04, in that after a reboot, WHS either sees the drives as missing, sees one and not the other, or sees both, but shows them not added to the pool (which I had done the first time I got WHS to see them (which took several reboots, i dont know why)
    When I first added the new external drives, my storage was at 56% on the 500gb, and 54%, 85% and 95% on the other three drives.
    WHS has yet to add any info to the drives and I now at 94% on the 500gb system drive and  66% 98% and 98% on the TB drives.


    And not sure if this is related, but when I went to look at the clent machine backups that were being saved, WHS obviously had not run a "cleanup" in several weeks, as I had many more copies of backups as my schedule called for.  Multiply this by the 5 machines that are backed up and I have about 4-5 extra "complete backups" and 6-7 "incomplete" or "cancelled" backups FOR EACH MACHINE (the "incomplete" backups strangely were flagged with a lock to keep?........... why would the system want to keep an incomplete or cancelled backup?)

    So, I tried to run "Clean Backups Now" after spending an hour going thru each of the machines backup copies and flagging all the extras and incomplete backups to be deleted.....then cliked on the Clean Backups Now button and the program appears to have started but after 24 hours, there was still no progression on the progress bar, so i rebooted the system.

    I tend to believe these two issues are NOT related.

    So, any ideas why the ESata connection is not "stable"?

    (And yes, I have checked all the cables and drives to ensure the failure isnt outside of the WHS)

    I will look forward to hearing there is a simple solution.

    Thanks

    Jay





    Jay
    Wednesday, March 11, 2009 7:08 PM
  • There is nothing on the drives because they keep getting repartitioned to unallocated. I do not have another machine with ESATA to test it out on. When i use the USB connection on it, it seems to work fine. For some reason i can format the drive and partition it to NTFS. Once i reboot it seems like it deletes the partition and makes the whole drive unallocated. This happens regardless if i add it to the HDD pool or not. Seems like there is an issue with the ESATA in WHS?

    Wednesday, March 11, 2009 9:46 PM