none
Validation using Open XML Package Editor RRS feed

  • Question

  • I don't have a lot of experience in VS so please bear with me.

    I'm using Open XML Package Editor to add ribbon customization to Word templates, saving as dotm and everything works pretty well except, I think, the validation of the XML. The XML syntax checking seems to be working fine but the validation of the XML isn't working when I'm editing a template.

    For instance, if I delete the close "of the tab" element I get this error:

    BUT, when I duplicate that tab using the same id, which is not allowed (by the schema?), I DON'T get a warning when I'm editing an OpenXML package (a dotm file):

    HOWEVER, if I create a new XML file in Visual Studio by selecting File, New, New File (Ctrl + N) and using the "XML File...General" then paste that EXACT SAME CODE, I DO get a warning:

    What would make that validation (and I may be using the wrong term here) NOT work when editing the template? In both instances the same schemas are selected / active in the VS "XML Schemas" dialog so I can't find what I'm missing.

    Working in VS 2012, by the way.

    Thanks very much for any help,
    Ken

    Tuesday, May 22, 2018 12:10 PM

All replies

  • Hello KenKrugh,

    Open XML Package Editor not a built-in tool but a third-part tools and I would suggest you contact their support team for your issue.

    For current thread, I will move it to Off-Topic  forum. Thanks for understanding.

    Best Regards,

    Terry


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, May 23, 2018 1:45 AM