locked
Inefficient 'Disk Removal' Routine RRS feed

  • General discussion

  •  

    It would seem that the procedure for removing a disk drive from WHS is written in a poor manner.  I emptied the contents of a 1TB external HD into my home server (which had 1.5TB of attached drive at the time) and then added the drive to the WHS storage.  I immediately realized that I still had it connected by USB when I meant to have it connected by Firewire, so I hit "remove".  It had not been connected for even 60 seconds.  It has now been on the "Remove a Hard Drive" status dialog for over four hours and counting...

     

    That it would take many hours to remove a drive that HAD to be empty is absurd.  It implies to me that the remove drive routine must be walking through the entire contents of the storage system and ensuring that each one is not on the drive about to be removed, rather than walking the drive about to be removed and moving files off it.  Probably made sense at the time it was written, but in this scenario the behavior looks a bit insane.  Not to mention wasting my whole afternoon of progress on getting this thing set up.

     

     

    Friday, December 28, 2007 10:17 PM

All replies

  • Can you move a hard drive from USB to Firewire or Sata with out removing it and re attaching it.

    Thursday, January 3, 2008 3:27 PM
  • I assume that you can, presumably each HD has a file system in it analogous to the database under a version control system and would work regardless of how it was attached to the system.  Didn't occur to me to even try it until it was too late and the removal process was already grinding away.

     

    Thursday, January 3, 2008 6:09 PM
  •  

    Like the person above I installed a second 500GB drive and 60 seconds later decided to remove it via the Remove wizard.  It went on for hours and then exited with an error and said to try again!!  I'm on my second attempt and this is just rediculous.

     

    What's wrong with the remove algorithm?  What is it doing that its taking so long?  And why would it have that much to do if I just installed the second drive?  It should be empty!!

     

    Explanation please.

     

    Jeff

     

     

    Monday, March 10, 2008 6:09 AM
  • I have the same problems.

     

    I have added an old usb drive.I want to remove it. I have at least three issues:

    1. I don’t want to start a wizard and then have to wait for calculation (calculate available space) that can take more than 30 minutes and press the finish button. I want to be able to indicate start moving files and in case you cannot move all. Indicate me in the end.
    2. The disc space is calculated in cases this is not necessary. In case I want to remove a 100 GB disc and I have at least 1 TB free space available I do not want to want half an hour.
    3. The remove function stops working. It does not indicate it. You can see it in the task manager and the disk manager nothing is happening. You have to reboot and start the remove disk process again. It should be possible to resume where it failed.
    Monday, April 14, 2008 6:39 AM
  • Some acknowledgement from the WHS team that they are aware of this issue for future attention would be nice.

     

    The current removal behavior will always be slower than it should be, even on a full drive.

     

    The really odd thing to me is that even if it were checking every single item in the spanned file system against the drive to be removed, just doing a check is essentially a database operation and should be very quick, it shouldn't involve actually *touching* and *manipulating* every single file... so what exactly is going on when a drive is removed, even an empty one, that takes so long?  Hmm?

     

     

    Monday, April 14, 2008 1:54 PM
  •  

    About the empty drive, it probably wasnt empty if it was available to WHS for any lenght of time. Let me give you my example.

     

    I had a drive failing, which would cause a BSOD in NTFS.SYS. I attached a USB drive to add enough space to remove the drive and install a replacement. I would start the removal process, and at some point the server would BSOD. As soon as the system came back up and I could open disk management and/or the WHS console, the drive migrator had "balanced 2 GB of data BACK onto the drive I wanted to remove! I hit remove, and watched the migrator move 5 MORE GB of data back before the migrator realized I wanted to remove the drive, and the size started going down again. It took me 3 days to remove a 60GB drive due to not always being available when the server BSODed (gotta sleep sometime!)

     

    I tried disabling the drive migrator service, but guess what WHS uses to move the files OFF of the drive to be removed? Yup, Drive Migrator.

     

    My "suggestion(s)"

    #1 have "balancing" happen a predetermined time after the system boots or a new drive is added

    #2 have a way to manually start and stop "balancing" for those who dont want to wait after installing a drive, or who want to wait when removing a drive.

     

    **Edit**

    Oh yea, and every time I tried to remove that drive after the first try, it told me i would permanently lose files, with no indication of what files would be lost! It shouldnt be loosing files as I had installed an 80GB USB drive to hold what was on the 60GB drive.

     

    #3 Have a link on the warning that gives a list of files that could be potentially lost so we can make an educated guess as to clicking continue or cancel.

     

    FYI in my case, I checked the drive after it was fully removed and it appears the warning was due to some partial files with numbers tacked on the end. I checked the files that matched the first part of the filename and they were complete, so it appears to be something that didnt get cleaned up properly during the BSOD reboots.

    Tuesday, April 29, 2008 7:03 PM
  • I stopped using the remove disk function. It does not work . At least for USB drives (I had two drives connected).

     

    First advice: do not connect USB drives.

     

    The way I remove a USB disk is:

    • disconnect the drive
    • remove the drive from the list
    • connect the drive to a pc and check the content on the disk

     

     

     

     

    Tuesday, April 29, 2008 7:36 PM
  •  

    I'm just in the process of moving to a new server and also had a usb drive attached for 15 minutes and it's taking hours to remove it. It seems like the process of adding a drive immediately allocates space wich takes hours to remove.

     

    I know that programming and testing has become difficult for a lot of people but there must be a way to improve this process. It seems like making a simple program is more important then functionality for the users. And surely if someone had tested adding and quickly after that removing a drive this would have been noticed as wrong.

     

    If it would allocate per file that's moved to the extra space it becomes much easier te remove a drive that has been attached for a short time.

     

    Regards,

     

    Constant Govaard

    Monday, May 12, 2008 9:20 AM
  •  jpantuso wrote:

    Some acknowledgement from the WHS team that they are aware of this issue for future attention would be nice.

     

     

    We are aware of this issue and working to address it in Power Pack 1. 

    Tuesday, May 13, 2008 8:12 PM