locked
CRM 4.0 Report Error. Report can't be displayed again RRS feed

  • Question

  • Hi,

    On Tuesday 19 January, I wrote the entry: http://social.microsoft.com/Forums/en-US/crmdeployment/thread/cd0231f2-63ae-4b2c-a19f-3a8d77a79c98

    I had problems with the View FilteredActivityPointer. Ok, to solve it in my two of my installations I set the permissions to SELECT the View. The result: one server works fine, lets say server1. The other, lets say server2, has a new problem.

    For some strange reason Server2 did not has installed SQL Server Management Studio and I decided to install the Express version of SSMS for SQL Server Enterprise (as I read that this can be installed for all versions of SQL Server 2005).
    After installation, I made the changes to the View FilteredActivityPointer setting the necessary permission to be able to SELECT for CRMReaderRole ReportingGroup group, as I did for server1 (actually working).

    Finally when I tried to run a report again and I saw a new error that just says "ERROR". After that I look at Event Viewer and this is what I found:

    Event Type: Error
    Event Source: MSCRMReporting
    Event Category: None
    Event ID: 19968
    Date: 21/01/2010
    Time: 07:50:15 PM
    User: N / A
    Computer: SERVIDORCRM
    Description:
    Web service request to Report Server ListExtensions
    http://servidorcrm/ReportServer/ReportService2005.asmx failed.
    Error: The request failed with HTTP status code 403:
    Forbidden.

    For more information,
    see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    I tried what appears in this other entry: http://social.microsoft.com/Forums/en-US/crmdeployment/thread/e82af1a2-d0a8-478e-ad29-f0aacb77fc11
    but nothing.

    Any ideas?
    Honestly I'm not sure if the reports were used before making the changes, but I remember that at least I was getting the error when trying to do SELECT on FilteredActivityPointer and now doesn't even that.

    Thank you.
    Friday, January 22, 2010 12:15 AM

All replies

  • Well I got more information about this error.

    I noticed that the server name in the URL it is running okay. The problem is that it is pointing to the correct port.

    Web service request to Report Server ListExtensions
    http://servidorcrm/ReportServer/ReportService2005.asmx failed.
    Error: The request failed with HTTP status code 403:
    Forbidden.

    It should be http://servidorcrm:81/ReportServer/ReportService2005.asmx

    After that I checked to Reporting Services Configuration Manager and discovered that the Report Server was on the Default WebSite and was not pointing servidorcrm:81 instead (port for my CRM installation).

    In Repoting Services Configuration Manager everything is set. Yet still gives the 403 error that the CRM when trying to run the report is pointing to port 80 and not 81.

    So:

    Reporting Services Connector is able to be repaired - reinstalled?
    They think they can solve my problem by reinstalling the connector?

    Thank you.

    Wednesday, January 27, 2010 4:56 PM
  • Ricardo,
    When you navigate to: 
    What happens?
    Additionally, when you navigate to:
    Does anything come up? Do you get the same 403 error in Internet Explorer?

    If you open Internet Information Services Manager, how many websites do you see?
    Is there the "Default Website" and the "Microsoft Dynamics CRM" website? Or is there only the Default?
    Can you check in IIS Manager to see which port the Default Website is running on, and which port the CRM website (if its different) is running on?

    Lastly, did the connector install complete successfully? Were there any errors or warnings you ran into?
    Also, what version of Windows Server are you running:
    Windows Server 2003 32 bit
    Windows Server 2003 64 bit
    Windows Server 2008 32 bit
    Windows Server 2008 64 bit

    and what Version of SQL Reporting Services did you install? What Service Packs were applied?
    SQL Reporting Services 2005 32 bit with SP2
    SQL Reporting Services 2005 32 bit with SP3
    SQL Reporting Services 2005 64 bit with SP2
    SQL Reporting Services 2005 64 bit with SP3

    Chances are you need to modify the ReportingServices config file manually, but I just want to make sure you've got everything set-up properly
    Thanks!
    -Paul


    Wednesday, January 27, 2010 7:24 PM
  • Hi Paul

    I just got more information about this problem... I think somebody tried (or just did it) to install Exchange server. So, here are my awnsers:

    First of all, the versions:
    Windows Server 2003 Enterprise x64 SP2
    and SQL Server 2005 x64 SP2 as well.

    At this moment if I navigate to http://servidorcrm:81/ReportServer I got the rsAccessDenied Error.
    Just for the record, I created a new virtual Diractory for the ReportServer for the  CRM website recently, afert I found it was ponting to DefaultSite instead.

    If I navigate to http://servidorcrm:81/Reports I'm able to see the Report manager. No folders, no reports are showed.

    Deafult site is on port 80 and I can see a lot of virtual direcotries: Autodicover, EWS, Exchange, Exchweb and ReportServer. This sites has a SSL port specified so that explains the 403 error when it try to call http:// and not https:// instead.

    I think I'm getting to the root of this. Any suggestions?
    Does exchange server installation has chanched everything? I think so, but, how can I restor it? By modifying ReportingServices config?

    Thanks.
    Wednesday, January 27, 2010 8:10 PM
  • Ricardo,
    Just a few more things... when you go to  http://servidorcrm/ReportServer what do you see exactly? 
    Why did you create a new VirtualDirectory for ReportServer on port 81?
    What port is CRM running on (The CRM website)? 

    I would recommend that you change the ReportServer back to a VirtualDirectory on the Default Website (the same as the Reports virtual directory) since the ReportServer and Reports VDirs shouldn't necessarily be on the same site as CRM anyways. 

    -Paul
    Wednesday, January 27, 2010 10:05 PM
  • Hi Paul,

    When I go to http://servidorcrm/ReportServer I see an error 403 cause it seems to have ssl security enabled.
    The reason why I creted a new VirtualDirectory for ReportServer on port 81 because the ssl security enabled on port 80.

    CRM web site is running on port 81.

    If I change the Virtual Directory to Default Site I will get an error message when I type http://servidorcrm:81/reports and http://servidorcrm:81/ReportServer. That's why I keep it, at least I'm not getting the error in both sites (CRM and Report Manager).

    Thanks.
    Friday, January 29, 2010 9:06 PM