none
VBScript CreateObject( "ADODB.Recordset" ) returning empty RRS feed

  • Question

  • Hello,

    Looking for assistance troubleshooting/diagnosing an issue that is showing up with a Classic ASP/VBScript web application I am currently supporting. Over the past couple of weeks I've had users reporting issues in the app, troubleshooting with them I've been able to narrow down the issue to creation of a "ADODB.Recordset" in client side VB Script.

    To test/confirm this I added the below to a dev environment and had the users experiencing issues connect.

      Dim testRs             

       set testRs = CreateObject( "ADODB.Recordset")

       msgbox TypeName(testRs)   

    What I am seeing is the users having issues are getting "Empty" back. Users not experiencing issues get a type back of RecordSet. For the users experiencing issues this leads to a 424 object required error when attempting to do anything with the object.

    To be clear this is currently a workstation specific issue, the users reporting problems are not experiencing problems on another workstation. I'm currently working with them to identify what may have changed but we haven't been able to pinpoint anything yet. We are all on Windows 7 Enterprise, using IE11.

    This is an older application, nothing has changed in quite some time. I've confirmed all users are accessing the site in compatibility mode (intranet site).

    If anyone can provide guidance/insight on how I can further troubleshoot/pinpoint the issue I would greatly appreciate it.

    -Thanks

    • Moved by Reed KimbleMVP Monday, July 9, 2018 5:14 PM VBS in VB.Net
    • Moved by Bill_Stewart Tuesday, December 11, 2018 8:44 PM Unanswerable drive-by question
    Monday, July 9, 2018 4:03 PM

All replies

  • Hi,

    I'm sorry but you've posted to the VB.Net language forum.  VB Script is something quite different and is not supported here.  I will move this thread to a forum that supports scripting.

    While you wait though, check for a permissions issue for this one affected user.  That could be the reason it isn't working for just one account.


    Reed Kimble - "When you do things right, people won't be sure you've done anything at all"

    Monday, July 9, 2018 5:10 PM
  • This is not a scripting issue.  You likely have issues with the object registrations.

    Without the complete error message there is no way to know what might be happening.

    Start by writing the least amount of code to test the recordset retrieval.


    \_(ツ)_/

    Monday, July 9, 2018 5:28 PM