locked
Workflows not working! RRS feed

  • Question

  • The Workflows that I created to activate after an Opportunity is closed as WON do not seem to be working

    These workflows are set up to send emails when a Opportunity is marked WON.  This is the only stipulation and yet when I test this process with an Opportunity I created, nothing is sent out.

    I have checked that the workflows are in Activated status and the conditions to activate the workflow are being met, yet the email notifications are not going out and the Workflows are not listed in the list of System Jobs (Settings > System Jobs).

    Am I missing something here?  Is there a better way to set up this kind of workflow?

    Thank you

    Nicole

    Thursday, April 23, 2015 3:55 PM

All replies

  • Nicole,

    1.  Check the Async service to see if it is running.  You will need to log onto the desktop of the CRM server, then click start and navigate to services.  If it is not running, start the service.

    2. Check the scope of the workflow.  You may need to set it to Organization level.  You will need to unpublish the workflow to make this change.  This setting is similar to a privilege setting in a security role.  It allows the workflow to see the records it should fire on.  Test is this change allows the workflow to fire.

    3. If you still have issues where the workflow doesn't fire, see if you can temporarily test with a user who has the sys admin security role just to make sure it isn't a privilege issue.  If you can't do this, then create a simple workflow that runs on demand to do something like create a task when you run it from one of the out of the box entities.  This will also prove it isn't a security role issue.

    4. For testing, you may also not want to allow the workflow to clean up completed jobs.  This could give a false impression that the workflow didn't actually run if this was turned on.  It could have ran successfully according to logic, and deleted the job before anyone noticed.  By default it is off, and it is a setting on the admin tab of the workflow when editing the workflow.


    Jason Peterson

    Thursday, April 23, 2015 5:04 PM
  • How do you have CRM connected to your Exchange server?  Do any emails come out of CRM, like if you did one manually?

    The postings on this site are solely my own and do not represent or constitute Hitachi Solutions' positions, views, strategies or opinions.

    Thursday, April 23, 2015 7:45 PM
  • Hello Nicole,

    Can you confirm that once the workflow is run if a email record is created in CRM or not?

    If the records are being created using workflow and are not being sent then you need to check that the user must have access and privileges to send email. 


    Regards, Abhishek Bakshi If you find this post helpful then please Vote as Helpful and Mark As Answer. Check my blog on https://mydynamicscrmblog.wordpress.com/

    Friday, April 24, 2015 4:19 AM
  • Hi Nicole,

    Apart from the things mentioned by Jason, Wayne and Abhishek you can also check the To field in the Email what you are setting it as. And who is triggering the workflow, if both are differnt then you will have to go to:-

    File > Options in CRM, then clicking the E-mail tab and ticking the top box, "Allow other Microsoft Dynamics CRM users to send e-mail on your behalf.", followed by OK, for the user set in the TO field.

    Meanwhile you can enable trace and get the exact issue in the logs.

    Thanks,

    Prasad

    Make sure to "Vote as Helpful" and "Mark As Answer",if you get answer of your question.

    Friday, April 24, 2015 6:32 AM