locked
Error using Report Wizard Reports in a deployment ('Microsoft.ReportViewer.Common, Version=11.0.0.0) RRS feed

  • Question

  • Hi,

    I have a deployment where I can't use Report Wizard Reports. It's an organization upgraded from CRM 4 and initially I thought it was an upgrade issue but I found that the reports are working in our lab environment where we did the upgrade. I get an error in the trace files saying the following:

    [2014-11-04 13:26:09.216] Process: w3wp |Organization:00000000-0000-0000-0000-000000000000 |Thread:   25 |Category: Platform |User: 00000000-0000-0000-0000-000000000000 |Level: Error |ReqId: eae145f6-b7db-4b07-be53-b9dc088de036 | ExceptionConverter.ConvertMessageAndErrorCode  ilOffset = 0x23B
    >System.IO.FileLoadException: Microsoft Dynamics CRM has experienced an error. Reference number for administrators or support: #8A8AFC42: System.IO.FileLoadException: Could not load file or assembly 'Microsoft.ReportViewer.Common, Version=11.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)
    >File name: 'Microsoft.ReportViewer.Common, Version=11.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91' ---> System.IO.FileLoadException: The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)
    >   at Microsoft.Reporting.WebForms.LocalReport..ctor()
    >   at Microsoft.Reporting.WebForms.ReportViewer.CreateReportHierarchy()
    >   at Microsoft.Reporting.WebForms.ReportViewer..ctor()
    >   at ASP.lab_crmreports_rsviewer_quirksreportviewer_aspx.__BuildControlreportViewer()
    >   at ASP.lab_crmreports_rsviewer_quirksreportviewer_aspx.__BuildControlform1()
    >   at ASP.lab_crmreports_rsviewer_quirksreportviewer_aspx.FrameworkInitialize()
    >   at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
    >   at System.Web.UI.Page.ProcessRequest()
    >   at System.Web.UI.Page.ProcessRequest(HttpContext context)
    >   at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
    >   at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
    >
    >
    [2014-11-04 13:26:09.217] Process: w3wp |Organization:00000000-0000-0000-0000-000000000000 |Thread:   25 |Category: Platform |User: 00000000-0000-0000-0000-000000000000 |Level: Error |ReqId: eae145f6-b7db-4b07-be53-b9dc088de036 | ExceptionConverter.ConvertToFault  ilOffset = 0x69
    >UNEXPECTED: no fault?
    [2014-11-04 13:26:09.217] Process: w3wp |Organization:00000000-0000-0000-0000-000000000000 |Thread:   25 |Category: Platform |User: 00000000-0000-0000-0000-000000000000 |Level: Error |ReqId: eae145f6-b7db-4b07-be53-b9dc088de036 | ExceptionConverter.ConvertMessageAndErrorCode  ilOffset = 0x23B
    >System.IO.FileLoadException: Microsoft Dynamics CRM has experienced an error. Reference number for administrators or support: #13114A3A: System.IO.FileLoadException: The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

    Have anyone else had this problem and what is the resolution? Is the reportviewer component needed on the CRM server or the SSRS server and why isn't it installed if needed? Another part of this problem is that the GAC looks different on out lab server than it does on the SSRS server and the CRM server so it's a bit hard to compare what's the difference.

    Thanks


    Rickard Norström Developer CRM-Konsulterna
    http://www.crmkonsulterna.se
    Swedish Dynamics CRM Forum: http://www.crmforum.se
    My Blog: http://rickardnorstrom.blogspot.se

    Tuesday, November 4, 2014 1:29 PM

All replies