locked
Event Source: ASP.NET 2.0.50727.0 Event ID: 1309 RRS feed

  • Question

  •  

    Event Type: Warning
    Event Source: ASP.NET 2.0.50727.0
    Event Category: Web Event
    Event ID: 1309
    Date:  6/9/2010
    Time:  7:44:13 AM
    User:  N/A
    Computer: TestServer01
    Description:
    Event code: 3005
    Event message: An unhandled exception has occurred.
    Event time: 6/9/2010 7:44:13 AM
    Event time (UTC): 6/9/2010 12:44:13 PM
    Event ID: 985abeba8138465583e7464af9b4ef42
    Event sequence: 138
    Event occurrence: 11
    Event detail code: 0
     
    Application information:
        Application domain: /LM/W3SVC/1146653513/Root-1-129205430502729423
        Trust level: WSS_Minimal
        Application Virtual Path: /
        Application Path: C:\Inetpub\wwwroot\wss\VirtualDirectories\Test\
        Machine name: TestServer01
     
    Process information:
        Process ID: 1364
        Process name: w3wp.exe
        Account name: Domain\SPAppPool
     
    Exception information:
        Exception type: WebException
        Exception message: The request failed with HTTP status 401: Unauthorized.
     
    Request information:
        Request URL: http://test/epm/sfdc globalization (americas)/default.aspx
        Request path: /epm/sfdc globalization (americas)/default.aspx
        User host address: 10.10.10.10
        User: Domain\SPContent
        Is authenticated: True
        Authentication Type: Negotiate
        Thread account name: Domain\SPAppPool
     
    Thread information:
        Thread ID: 6
        Thread account name: Domain\SPAppPool
        Is impersonating: False
        Stack trace:    at Microsoft.Office.Project.Server.WebServiceProxy.PSIProxyBase.InvokePSI(String serviceName, String methodName, Object[] parameters)
       at Microsoft.Office.Project.Server.WebServiceProxy.Security.CheckUserGlobalPermissions(Guid[] globalPermissionUids)
       at Microsoft.Office.Project.PWA.WebParts.TaskPart.OnInit(EventArgs e)
       at System.Web.UI.Control.InitRecursive(Control namingContainer)
       at System.Web.UI.Control.AddedControl(Control control, Int32 index)
       at System.Web.UI.WebControls.WebParts.WebPartManager.WebPartManagerControlCollection.AddWebPartHelper(WebPart webPart)
       at System.Web.UI.WebControls.WebParts.WebPartManager.WebPartManagerControlCollection.AddWebPart(WebPart webPart)
       at System.Web.UI.WebControls.WebParts.WebPartManagerInternals.AddWebPart(WebPart webPart)
       at Microsoft.SharePoint.WebPartPages.SPWebPartManager.AddWebPartWithRetry(WebPart webPart)
       at Microsoft.SharePoint.WebPartPages.SPWebPartManager.AddDynamicWebPart(WebPart webPart)
       at Microsoft.SharePoint.WebPartPages.SPWebPartManager.CreateWebPartsFromRowSetData(Boolean onlyInitializeClosedWebParts)
       at Microsoft.SharePoint.WebPartPages.SPWebPartManager.LoadWebParts()
       at Microsoft.SharePoint.WebPartPages.SPWebPartManager.OnPageInitComplete(Object sender, EventArgs e)
       at System.EventHandler.Invoke(Object sender, EventArgs e)
       at System.Web.UI.Page.OnInitComplete(EventArgs e)
       at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
     
     
    Custom event details:

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

     

     

    Can somebody tell me how to fix this warning message

    • Moved by Mike Walsh FIN Wednesday, June 9, 2010 3:22 PM Project Server in message and also PWA isn't in SP it's only in Project Server. Post such questions to the Proj Server forum (From:SharePoint - Setup, Upgrade, Administration and Operation (pre-SharePoint 2010))
    Wednesday, June 9, 2010 1:10 PM

Answers

  • Thanks David,

    I suspect that the issue may be due to following reasons.

    1. Customization done on the project web parts

    2. Project or other web parts on the workspace

    Try:

    1. Remove any project web part if you added in the project workspace.

    2. Synchronize the workspace permissions with the project plan if possible.

    3. If possible disconnect the workspace from project plan and attach it back.

    4. If it is a low priority site, take a backup, delete it, import the site from backup. (Last option)

     


    Thanks Sriram E - MSFT Enterprise Project Management
    Thursday, June 10, 2010 3:45 PM

All replies

  • Hi there.

    It seems that your SharePoint application is trying to access an external resource located at http://test/epm/sfdc globalization (americas)/default.aspx , and is getting an access denied. Most probably because your SharePoint application pool account Domain\SPAppPool doesn't have permission to browse/access this resource.

    Try to allow it to access this resource and see if the error message goes away.

    Hope this helps.

    Regards,

    Magnus

     


    My blog: InsomniacGeek.com
    Wednesday, June 9, 2010 1:28 PM
  • that is the location of my of my Microsoft Project Site (PWA) that is on the server. The site is run under the same application pool
    Wednesday, June 9, 2010 1:57 PM
  • Hello DavidLewis27

    Did you happen to see this article? Are you running TFS?  Is this Project Server 2007?  Are you seeing this as recurring often in your logs?  How often? 

    http://support.microsoft.com/kb/974402/ru

    cheers!

    Michael Wharton, MBA, PMP, MCT


    Sincerely, Michael Wharton, MBA, PMP, MCT, MCSD, MCSE+I, MCDBA www.WhartonComputer.com
    Wednesday, June 9, 2010 4:47 PM
  • Hi Michael Wharton,

    I will take a look at your article.  I am running Project Server 2007.  The waring happen once every hour.

     

    Thanks,
    David Lewis

    Wednesday, June 9, 2010 8:48 PM
  • http://test/epm/sfdc globalization (americas)/default.aspx 
        User: Domain\SPContent
        Is authenticated: True
        Authentication Type: Negotiate

    What is your PWA url? ( is it http://test/epm or http://test/epm/sfdc globalization (americas) ?)

    If the first one, then the second one must be a Project workspace (project site)? Is it available?

    Are you using Kerberos? If yes, is that URL configured in SPN?


    Thanks Sriram E - MSFT Enterprise Project Management
    Wednesday, June 9, 2010 10:48 PM
  • Sriram you are correct the first one is my PWA URL and the second one is a project workspace.  Yes it is available and accessible.  I am using kerberos and the SPN has been configured

    Thursday, June 10, 2010 1:03 PM
  • Thanks David,

    I suspect that the issue may be due to following reasons.

    1. Customization done on the project web parts

    2. Project or other web parts on the workspace

    Try:

    1. Remove any project web part if you added in the project workspace.

    2. Synchronize the workspace permissions with the project plan if possible.

    3. If possible disconnect the workspace from project plan and attach it back.

    4. If it is a low priority site, take a backup, delete it, import the site from backup. (Last option)

     


    Thanks Sriram E - MSFT Enterprise Project Management
    Thursday, June 10, 2010 3:45 PM