locked
Issue when loading an opportunity with an iframe custom aspx page in Outlook 2013 Client RRS feed

  • Question

  • Hello,

    Scenario:

    I have a custom web application that I load via an IFRAME in CRM 2013, for the opportunity workflow.

    It is using the AjaxToolKit, Visual Studio 2013 Update 2, and the site is hosted in the cloud and on-premise.

    When I load the CRM site itself and go to the opportunity, it loads the iframe fine and things are great.

    When I go into Outlook 2013 and go to my CRM organization, and then to the Opportunity and open it, instead of loading the iframe correctly, it get the following errors.

    AjaxControlToolKit requires ASP.NET AJAX 4.0 scripts

    Then I get these

    object doesn't support property or method registerComponent

    Since this works fine as a stand alone web app, and it works fine when its specifically being loaded in the full CRM client (online or onpremise), I have to assume it's something specific to when it's being "opened" from OutLook 2013.

    It has no ScriptManagers. It's not a "master page" scenario" It's all just separate ASPX pages. Each page has a ToolKitManager (that's it). Everything runs great in all scenarios (phone, web, embedded iframes etc), except in outlook. And BTW, if I embed it within an outlook plug-in it works fine.

    Just not in the CRM stuff that runs in Outlook

    I looked in the event logs, nadda. I tried to debug it specifically and nadda either..

    Any suggestions

    Friday, June 6, 2014 9:34 PM

All replies

  • That's a bummer, no ideas at all from the prod / support team?
    Monday, June 9, 2014 8:56 PM