none
Remote access setup RRS feed

  • Question

  • I'm evaluating the trial of WHS, having installed it on an old pc I had (P4, 2.something Ghz, 1GB ram).  It installed fine, I can access it and interact with it from my computers; my problem is, when I try to set up remote access, it always fails at the point when checking to see if the website is accessible from the internet.

    I've let it try many, many times to repair whatever might be ailing, I've manually opened ports 80, 443, & 4125 on both the modem and the router, so they shouldn't be an issue.  My internet connection works fine, that isn't the issue.

    I just can't figure out what is the problem.

    One time it passed, but then it immediately failed when trying to setup a domain name.

    I'm at a loss; not being able to remote access would be a dealbreaker.

    I have an Actiontec DSL modem, going into a dlink WBR-2310 wireless router; AT&T is my ISP.  There's nothing in my service agreement which prevents me from having a server.

    Any ideas?
    • Edited by SteveC33 Saturday, February 6, 2010 1:53 PM
    Saturday, February 6, 2010 4:39 AM

Answers

  • Olaf,

    I just finished solving my issue this way:

    My dsl modem also has additional ethernet ports, so I plugged the server and my desktop computer into these, and then also my wireless router into this, but only as another device (essentially acting as a subnet).  This worked; every computer sees the server, I have wireless, and I was able to set up remote access and my domain.

    Thanks for your help.

    Steve
    • Marked as answer by SteveC33 Saturday, February 6, 2010 5:07 PM
    Saturday, February 6, 2010 5:07 PM

All replies

  • You said, you "opened" the ports on modem and router. Opening is wrong here, you should forward the ports. If the router and the modem are not bridged, they represent a double NAT scenario, which is more difficult to handle. In this case you need to redirect incoming requests for each of these ports in the modem configuration to the same port on the external interface of the router and and do the same for the router by forwarding to the servers internal address. The better way would be an all in one router, which has a built in modem already.

    In the own network this test may fail anyway, since many routers do not support loopback access (accesing your home from your home via Internet). This may cause the failure message, so this can be ignored, as long as all other stuff is working.

    Best greetings from Germany
    Olaf
    Saturday, February 6, 2010 9:48 AM
    Moderator
  • Olaf,

    Thanks for your reply.

    I mispoke; I did forward the ports, not open them.  The ports are forwarded from the dsl modem to the router, and the ports are forwarded from the router to the server.

    I can't check to see if I have access from outside my network, becasue it won't allow me to set up a domain name.
    Saturday, February 6, 2010 1:53 PM
  • Hi Steve,
    did you try if a reboot of the server would solve something?
    Can you use Internet Explorer on the server to connect to the Internet and especially to the Microsoft website?
    Do you get any detailed error message on screen or in the event logs?
    Check also the logs in Start/Run %qlogs% near of a failed attempt for related information.

    Best greetings from Germany
    Olaf
    Saturday, February 6, 2010 4:44 PM
    Moderator
  • Olaf,

    I just finished solving my issue this way:

    My dsl modem also has additional ethernet ports, so I plugged the server and my desktop computer into these, and then also my wireless router into this, but only as another device (essentially acting as a subnet).  This worked; every computer sees the server, I have wireless, and I was able to set up remote access and my domain.

    Thanks for your help.

    Steve
    • Marked as answer by SteveC33 Saturday, February 6, 2010 5:07 PM
    Saturday, February 6, 2010 5:07 PM
  • The recommended configuration would be to place one or the other of your router-class devices into "bridge" mode. Doing so means that you'll only have one router, and everything will be relatively easy to configure. With the network topology you have now, clients that connect to your network wirelessly may not be able to communicate with your server.
    I'm not on the WHS team, I just post a lot. :)
    Saturday, February 6, 2010 7:41 PM
    Moderator
  • Ken,

    Thanks for your interest in my situation.

    I set up my wireless router according to the manufacturer's instructions for hooking it up to another router.  DHCP and UPnP are turned off, and the wireless router is assigned a static network address.  It isn't hooked up via the WAN port, but by a LAN port.  My laptop then uses this access point, which sees the rest of the network, including the server.

    Steve
    Saturday, February 6, 2010 9:17 PM
  • Okay, so you've already put the router into bridge mode. Good. :)
    I'm not on the WHS team, I just post a lot. :)
    Saturday, February 6, 2010 11:53 PM
    Moderator