locked
viewer RRS feed

  • Question

  • I am receiving this error while trying to access my online courses:

    "Unable to initialize the viewer. If you have installed the viewer to your computer, please re-run the Setup program. If you are accessing the viewer from a server, please contact your System Administrator."
    Saturday, November 1, 2008 5:29 PM

All replies

  • Not only you.
    Unfortunately, nobody from Microsoft is reading this forum.
    • Edited by DesTy Saturday, November 1, 2008 9:00 PM
    Saturday, November 1, 2008 8:59 PM
  • I am getting this error too for the last couple of days.
    Sunday, November 2, 2008 2:16 PM
  • I have also been getting this problem, however on Friday I purchased a Windows 2008 collection and that is working.  The previous subscriptions do not.
    Sunday, November 2, 2008 8:35 PM
  • Likewise i am also having the same problem with the same error. Even when using the offline lesson viewer it does not work giving an "Object Expected" error.
    Sunday, November 2, 2008 8:54 PM
  • What courses are people having trouble with?

    For me it is only Office 2007...
    Monday, November 3, 2008 6:51 AM
  • Hi all... this problem was hapening to me before couple days... it seems that you all using windows vista or a new version of IE...
    after you click on the download course button notice the IE which will ask you to download an activeX control.....
    Monday, November 3, 2008 8:25 AM
  • Can't use the offline version as it won't go through the corp firewall, can't use the online version (Office 2007 courses) because of the error referenced at the start of this thread. Is there any feedback from MS on when this will be fixed!!
    Monday, November 3, 2008 9:15 AM
  • Hi  This problem is also with us although only on a particular course 4697 so far and not with all PCs.  It worked fine on mine but not on a colleagues but they could run other courses without the error.  Very odd.
    Monday, November 3, 2008 9:49 AM
  • I also have the same problem. I have courses 5407-5424 but I cannot run any of them. I also tried to download the courses to my notebook but when I start any of them this error appears: "Object expected". Is there anybody who can help?
    If this is something to do with the problem, I am from Bulgaria..
    • Edited by batalizator Monday, November 3, 2008 10:28 AM
    Monday, November 3, 2008 10:26 AM
  • i am receiving the same error. please help i am using vindows vista premium.
    Monday, November 3, 2008 1:34 PM
  • I am also getting the same errors with Collection 5403: Have emailed Microsoft but they haven't responded yet.
    Monday, November 3, 2008 5:46 PM
  • I am having the same issue and I called customer service.  They had me clear my cache and try again, which I had already tried and did not succeed.  They opened a ticket for this issue, which apparently they say they were not aware of, and should get back to me in 2-3 business days!  I'll post any response that I may receive...

    Here is the number that I contacted: Telephone: (800) 456 0025, option 4

    I am also going to try contacting the Partner "Technical" Support Line: 888-677-9444
    • Edited by Student30 Monday, November 3, 2008 6:43 PM
    Monday, November 3, 2008 6:26 PM
  • i've the same problem with the hosted collection 5239 ~ 5243
    also online as offline
    Monday, November 3, 2008 7:41 PM
  • I am too getting the same error message with the 2261 course, tried on both my laptop as well as my PC.
    Monday, November 3, 2008 7:54 PM
  • Have a quick fix:
    Open start -> cmd
    then type:
     regsvr32 /u c:\Windows\system32\msxml6.dll
    [enter]

    Restart you elearning course. (ctrl + f5) And it works.

    After you are ready elearning you do the reverse for the fix:
    Open start -> cmd
    then type:
     regsvr32 c:\Windows\system32\msxml6.dll
    [enter]

    it seems to be a know issue.
     
    Michel

    • Proposed as answer by michelk Monday, November 3, 2008 8:18 PM
    Monday, November 3, 2008 8:18 PM
  • Nice work Michelk!  Unregistering the msxml6.dll seemed to work for the online course, but not for the offline viewer!  All I did was unregister the dll and the online viewer worked.  Re-registering the file did not seem to fix the offline course stuff, but it did, once again, break the online stuff.  Thus, I've unregistered the file and can at least work through my course work online! 

    MichelK, where did you get this fix from?
    Monday, November 3, 2008 9:23 PM
  • MS xml parser is useds by visual studio 2005. If i unregister that, Some Visual studio 2005 and sql server 2005 functionality stops working. How can I fix that? https://connect.microsoft.com/VisualStudio/feedback/ViewFeedback.aspx?FeedbackID=114656
    Monday, November 3, 2008 9:47 PM
  • This worked for me.  After the un-register of the file, the website installed the MSXML 5.0 Active X Control. It seems that the problem lies with version 6?

    Thanks michelk.



    Ben
    Monday, November 3, 2008 11:39 PM
  • Unregistering the msxml6.dll worked, but inconsistently and only on one of the laptops I use.  I contacted Microsoft and this is what they sent me - I followed the first option and the trainings are now working on both computers.

    ********************************************************************************

    Thank you for contacting Microsoft E-Learning Technical Support. This message is in response to your inquiry below.

    This issue has been addressed and corrected. If you are still experiencing this error, could you please delete your cache and cookies:

    1. Select Tools
    2. Select Internet Options
    3. Select Temporary Internet Files
    4. Select Delete Cookies
    5. Select Delete Files
    6. Close all browser windows and reopen a new one
    7. Re-launch the course

    If the error still occurs, please follow these steps:

    1. Close all Open Browser Windows
    2. Select Start --> RUN and input regsvr32 -u msxml6.dll and hit OK
    3. Select Start --> RUN and input regsvr32 msxml3.dll and hit OK
    4. Launch Course
    *****NOTE: Infobar may drop down from top of content window requesting student RUN msxml5.dll. Please ensure the student is aware of this and that the student right-clicks and selects Allow Active. Student may need to restart course window after Allowing ActiveX to run*****

    Wednesday, November 5, 2008 5:16 PM