locked
Installing updated version of NoReplyAll Add-in gives "Value does not fall within the expected range" error. RRS feed

  • Question

  • For reasons I don't know, the app disappeared from the directory it had been installed in.  I could not reinstall the old version, because it told me it was already installed.  Looking in A/R programs there was nothing there.  I went into the registry and searched for noreplyall and found multiple entries which I deleted, as well as the original directories.

    I could not install the old version, so came to the site to discover a new version.  I cannot install this now, with the error in the title. 

    The details of the error are:

     Name: NoReplyAllAddin

    From: file:///V:/Downloads/NoReplyAllAddin/NoReplyAllAddin.vsto

    ************** Exception Text **************

    System.ArgumentException: Value does not fall within the expected range.

       at Microsoft.VisualStudio.Tools.Applications.Deployment.ClickOnceAddInDeploymentManager.DownloadAddIn(TimeSpan timeout)

       at Microsoft.VisualStudio.Tools.Applications.Deployment.ClickOnceAddInDeploymentManager.InstallAddIn()

    I read the README.txt in the new version and saw that it referenced going to <localappdata>\Apps\2.0\<some gibberish>\<some gibberish> and deleting all the files.  I didn't notice the part about also digging into the manifests file.  Now that I have done that, I receive:

    Name:
    From: file:///V:/Downloads/NoReplyAllAddin/NoReplyAllAddin.vsto

    ************** Exception Text **************
    System.Runtime.InteropServices.COMException (0x800736B3): The referenced assembly is not installed on your system. (Exception from HRESULT: 0x800736B3)
       at Microsoft.VisualStudio.Tools.Applications.Deployment.ClickOnceAddInDeploymentManager.GetManifests(TimeSpan timeout)
       at Microsoft.VisualStudio.Tools.Applications.Deployment.ClickOnceAddInDeploymentManager.InstallAddIn()

    Monday, April 30, 2012 11:07 PM

Answers

  • Interestingly, just today I did come across a local machine exhibiting this problem, and deleting the ClickOnce files wasn't sufficient. I suspect that what I ended up doing was akin to using a sledgehammer to crack a nut, but I did get the thing to install!

    1) Delete ClickOnce files relating to the add-in - these are under <localappdata>\Apps\2.0\XXXX\YYYY, where XXXX and YYYY are strings of apparent gibberish (they're actually a magic id referenced in the registry, fwiw). There are three (or more, if you have had several versions installed in the past) directories here to get rid of, with names starting nore...dll_, nore.ddin_ and nore.vsto_ - I wonder if some other add-in with a similar name could cause confusion with mine... Alongside those directories is another called manifests: in there you will find six (or more) files, pairs of .cdf-ms and .manifest files with names starting with the same strings as above - delete all of those.

    In all cases I've come across until yours and today's, deleting those has been enough. But if it's not, fire up RegEdit...

    2) Clear out the SideBySide cache - Expand and check every key under HKCU\Software\Classes\Software\Microsoft\Windows\CurrentVersion\Deployment\SideBySide\2.0 and delete everything that refers to the add-in - again, the subkeys and values seem to have names following the same pattern as above.

    3) Do a search through all of HKCU for the string NoReplyAllAddin - there seem to be about half a dozen other references which should be deleted.

    As I said, this might well be overkill, but I was able to install the add-in successfully after all that. I'm afraid I don't understand why this installation problem occurs: I can't see what I might have misconfigured in my installer - it's so simple there's practically nothing for me to configure. If these problems crop up more often, I might have to think about creating a tool to do the cleanup for us...

    Please do let me know how you get on.

    • Marked as answer by Paul Nacamuli Wednesday, May 9, 2012 6:07 PM
    Wednesday, May 2, 2012 1:48 PM

All replies

  • (I hope that when you said deleted "all the files" above, you zapped only the noreply ones!)

    There's another question in this forum (http://social.microsoft.com/Forums/en-US/researchdesktop/thread/7ce435c0-46dc-4be5-8454-7f3021ed0ab9) which mentions some registry settings also related to ClickOnce installation which may be relevant here - I've not ever touched them myself, but Jnamosier found that she had to delete those to get a reinstall to work.

    A web search came up with:

    Do any of those help?

    Tuesday, May 1, 2012 6:09 AM
  • Interestingly, just today I did come across a local machine exhibiting this problem, and deleting the ClickOnce files wasn't sufficient. I suspect that what I ended up doing was akin to using a sledgehammer to crack a nut, but I did get the thing to install!

    1) Delete ClickOnce files relating to the add-in - these are under <localappdata>\Apps\2.0\XXXX\YYYY, where XXXX and YYYY are strings of apparent gibberish (they're actually a magic id referenced in the registry, fwiw). There are three (or more, if you have had several versions installed in the past) directories here to get rid of, with names starting nore...dll_, nore.ddin_ and nore.vsto_ - I wonder if some other add-in with a similar name could cause confusion with mine... Alongside those directories is another called manifests: in there you will find six (or more) files, pairs of .cdf-ms and .manifest files with names starting with the same strings as above - delete all of those.

    In all cases I've come across until yours and today's, deleting those has been enough. But if it's not, fire up RegEdit...

    2) Clear out the SideBySide cache - Expand and check every key under HKCU\Software\Classes\Software\Microsoft\Windows\CurrentVersion\Deployment\SideBySide\2.0 and delete everything that refers to the add-in - again, the subkeys and values seem to have names following the same pattern as above.

    3) Do a search through all of HKCU for the string NoReplyAllAddin - there seem to be about half a dozen other references which should be deleted.

    As I said, this might well be overkill, but I was able to install the add-in successfully after all that. I'm afraid I don't understand why this installation problem occurs: I can't see what I might have misconfigured in my installer - it's so simple there's practically nothing for me to configure. If these problems crop up more often, I might have to think about creating a tool to do the cleanup for us...

    Please do let me know how you get on.

    • Marked as answer by Paul Nacamuli Wednesday, May 9, 2012 6:07 PM
    Wednesday, May 2, 2012 1:48 PM
  • Gavin - thanks for the reply.

    I confirmed step 1 was done (yes, I only deleted the nore...)

    I did step 2, and tried to install.  Success!

    THANK YOU!

    • Marked as answer by Paul Nacamuli Wednesday, May 9, 2012 6:07 PM
    • Unmarked as answer by Paul Nacamuli Wednesday, May 9, 2012 6:07 PM
    Wednesday, May 9, 2012 5:56 PM
  • Gavin,

    I have installed version 2.6.1.0 on several machines.  Many XP SP3, Office 2007, after the install the user has the button group, but under Tools/Options/NoReplyAll, they cannot Apply the changed options.  They can only click OK, which does not preserve their choices.  I hope you can help me.  Thanks!

    Friday, December 7, 2012 2:55 PM
  • Is this problem specific to Office 2007? It'll take me a little while to get hold of an Office 2007 install to check if I've done something stupid for the property page saving.

    Possible workaround for the time being: make the settings you want on a machine with Office 2010 or 2013, then fire up regedit and export the settings under "HKEY_CURRENT_USER\Software\Microsoft Research Ltd\NoReplyAddin" and then import them on the Office 2007 machines.

    Saturday, December 8, 2012 8:39 AM
  • I've tried an Outlook 2007 install, and found that settings do appear to be correctly saved, but there is a problem with two of the controls on the property page which do not enable the Apply button. The idea is that changing any setting on that property page should mark the page as "dirty" which will enable the saving of the settings. Unfortunately, I seem to have missed out the "Disable reply all for all received messages" and "Interpret exclusion strings as regular expressions" buttons: clicking either of those doesn't cause Apply to be enabled, unlike all the other buttons.

    Workaround until the next release: click one of the other buttons twice (i.e., enable and disable the option, or vice versa) to cause Apply to be enabled, and then you can save the updated settings.

    Monday, December 10, 2012 10:54 AM
  • Release 3.0 is out now, which fixes these missing checks.
    Thursday, February 14, 2013 8:22 AM