locked
Forcing a full sync does not work for join table RRS feed

  • Question

  • So, as I mentioned previously (http://social.microsoft.com/Forums/en-US/syncdevdiscussions/thread/9221f7b1-1d66-4d06-a011-7ec354ff1723/), changing the columns in the client db deploys a new client db to my debug directory, and for some reason the snapshot initialization when running the wizard doesn't work. Maybe I ran the wizard before I added my new columns. I'm not sure.

    I force the sync by updating all of my tables, setting the a column's value back to itself.

    I am using Entity Framework, and I have a join table. This table has only two columns, a primary key for each table it is joining.

    That join table is the only table that does not sync. I tried setting those keys back to themselves... no joy.

    Thursday, November 18, 2010 4:45 PM

Answers

  • I had missed a table, and that table is used in conjunction with another table to form and Entity. The entity would not load because of that.

    Rar!

    There has got to be a better way to do a full sync.

    • Marked as answer by Joshua Chan Thursday, November 18, 2010 5:25 PM
    Thursday, November 18, 2010 5:25 PM