none
xmlrpc.php error at self hosted wordpress site

    Question

  • I have a wordpress site, rodaw.com, running for a couple years. Recently I
    upgraded wordpress to 3.x etc... and now am at 3.1.1. I've also installed wlw on
    a new machine and consequently is a newer version than I have previously used to
    post blogs with large jpg images. Now I'm getting xmlrpc.php 500 Internal
    Server Error. I haven't blogged with this large a picture for some time but have
    successfully in the past I believe prior to the upgrades. So not sure
    which version may have broken my ability to use wlw to post blogs with large
    images to rodaw.com

    I posted the same blog post with the same images from
    the same wlw to a Orchard CMS site with no problems.

    I do
    have upload_max_filesize = 8M in /etc/php.ini on rodaw.com

    Here is the
    wlw log file:

    WindowsLiveWriter,1.3436,None,00349,22-Apr-2011 22:12:11.548,"Creating a
    writable ribbon istream for C:\Users\jeffa\AppData\Roaming\Windows Live
    Writer\Ribbon.dat",""
    WindowsLiveWriter,1.3436,None,00350,22-Apr-2011
    22:12:14.708,"XML-RPC request:
    http://www.rodaw.com/xmlrpc.php
    <?xml
    version=""1.0""
    encoding=""utf-8""?>
    <methodCall>
    <methodName>metaWeblog.newMediaObject</methodName>
    <params>
     
    <param>
       <value>
        <string>1</string>
      
    </value>
      </param>
      <param>
       <value>
       
    <string>jeffa</string>
       </value>
      </param>
     
    <param>
       <value>[removed]</value>
     
    </param>
      <param>
       <value>
       
    <struct>
         <member>
         
    <name>name</name>
          <value>
          
    <string>IMG_0871.jpg</string>
          </value>
        
    </member>
         <member>
         
    <name>type</name>
          <value>
          
    <string>image/jpeg</string>
          </value>
        
    </member>
         <member>
         
    <name>bits</name>
          <value>
          
    <base64>[213949 bytes]</base64>
          </value>
        
    </member>
        </struct>
       </value>
     
    </param>
    </params>
    </methodCall>",""
    WindowsLiveWriter,1.3436,None,00351,22-Apr-2011
    22:12:14.708,"== BEGIN WebException
    =====================",""
    WindowsLiveWriter,1.3436,None,00352,22-Apr-2011
    22:12:14.708,"Status:
    ProtocolError",""
    WindowsLiveWriter,1.3436,None,00353,22-Apr-2011
    22:12:14.708,"System.Net.WebException: The remote server returned an error:
    (500) Internal Server Error.
       at
    System.Net.HttpWebRequest.GetResponse()
       at
    WindowsLive.Writer.CoreServices.HttpRequestHelper.SendRequest(String requestUri,
    HttpRequestFilter filter)
       at
    WindowsLive.Writer.CoreServices.XmlRpcClient.CallMethod(String methodName,
    XmlRpcValue[] parameters)
       at
    WindowsLive.Writer.BlogClient.Clients.XmlRpcBlogClient.CallMethod(String
    methodName, XmlRpcValue[]
    parameters)",""
    WindowsLiveWriter,1.3436,None,00354,22-Apr-2011
    22:12:14.708,"HTTP/1.0 500 Internal Server Error
    Connection:
    close
    Content-Length: 0
    Content-Type: text/html; charset=UTF-8
    Date:
    Sat, 23 Apr 2011 05:12:37 GMT
    Server: Apache/2.2.3 (CentOS)
    X-Powered-By:
    PHP/5.3.5



    ",""
    WindowsLiveWriter,1.3436,None,00355,22-Apr-2011 22:12:14.708,"==
    END WebException
    =======================",""
    WindowsLiveWriter,1.3436,Fail,00356,22-Apr-2011
    22:12:14.711,"WindowsLive.Writer.Extensibility.BlogClient.BlogClientHttpErrorException:
    Server Error - The server reported an error with the following web address:


    http://www.rodaw.com/xmlrpc.php


    500 Internal Server Error

    <had to delete rest to be within 3000
    character imposed by this forum>


    Life is terminal.
    Saturday, April 23, 2011 5:25 AM