locked
Robocopy: /IS option not working as expected on windows server 2012 RRS feed

  • General discussion

  • Hi All,

    I wrote a script to copy files older than 180 days from source to destination. I also wanted to remove the moved files from the source. However, if the files were already present at the destination, normally it did not remove the files from source. After digging a bit about robocopy found that /IS option should do that work.

    I wrote the script and tested on Windows 7 PC and it worked as expected. But when I ran it on the server 2012, it did not remove the files already present at destination from source. Is it a limitation of Robocopy for different versions of Windows or limiations with local and network paths?

    Note: I tested on Windows 7 PC with local source and destination paths but on servers I used network paths for source and destination.

    Script used on local Windows 7 PC:

    robocopy "C:\Users\xyz\Downloads\test" "C:\Users\xyz\Downloads\test - Copy" /e /mov /minage:180 /r:3 /w:5 /is /log+:C:\Users\xyz\Downloads\test.log

    Script used on server 2012:

    robocopy "\\network-path-source" "\\network-path-destination" /e /mov /minage:180 /r:3 /w:5 /is /log+:C:\Users\xyz\Downloads\test.log

    The files older than 180 days are moved but if the same file with same content are already present at destination then the file at the source is not removed as is expected by /MOV and /IS option.

    • Changed type Bill_Stewart Thursday, March 14, 2019 11:53 PM
    • Moved by Bill_Stewart Thursday, March 14, 2019 11:53 PM This is not robocopy support forum
    Wednesday, November 21, 2018 10:35 AM

All replies

  • This is not a support forum for robocopy (which is a Windows system utility).


    -- Bill Stewart [Bill_Stewart]

    Thursday, November 22, 2018 5:18 PM