locked
An invalid IP address was specified. RRS feed

  • Question

  • Has anyone experienced this nasty problem:

    After configuring our CRM installation as a Internet Facing Deployment, no one can access the CRM!

    An error saying: "An invalid IP address was specified." is displayed.

    The event error log says:

    Request information:
    Request URL: http://peanaweb3:5555/MSCRMServices/2007/CrmService.asmx Request path: /MSCRMServices/2007/CrmService.asmx User host address: 10.10.10.69 User:
    Is authenticated: False
    Authentication Type:
    Thread account name: NT AUTHORITY\NETWORK SERVICE

    I get the same error whether I access the CRM from our intranet or from the Internet.

    Hope someone can help because I'm in the doghouse right now. No one can use the CRM. Yikes!

    Thanks in Anticipation.

    Derek

    Oh! I also get a similar message when loading the mailbox ifno in the CRM email router. I uninstalled the email router, but this has not helped the original problem.

    Thanks again.


    Derek
    Monday, July 20, 2009 11:36 PM

Answers

  • Hi Derek,

    are you using a valid IP-Adress in the IFD-configuration?
    Please check the IP-Adress you used in the IFD-configuration.
    Do you use the IFD-Configuration Tool? If not, use it. You can find the tool here:
     

    http://support.microsoft.com/kb/948779/en-us


    Viele Grüße

    Michael Sulz
    axcentro GmbH
    MVP für Microsoft Dynamics CRM
    • Marked as answer by Derek_Berek Tuesday, July 21, 2009 6:56 PM
    Tuesday, July 21, 2009 6:42 AM

All replies

  • Hi Derek,

    are you using a valid IP-Adress in the IFD-configuration?
    Please check the IP-Adress you used in the IFD-configuration.
    Do you use the IFD-Configuration Tool? If not, use it. You can find the tool here:
     

    http://support.microsoft.com/kb/948779/en-us


    Viele Grüße

    Michael Sulz
    axcentro GmbH
    MVP für Microsoft Dynamics CRM
    • Marked as answer by Derek_Berek Tuesday, July 21, 2009 6:56 PM
    Tuesday, July 21, 2009 6:42 AM
  • Hi,

    if you use windows 2008 server, perhaps the following link will help http://support.microsoft.com/kb/950100
    Do you use IPv6-only or is IPv6 configured in addition to IPv4?
    Tuesday, July 21, 2009 9:50 AM
  • Hi Michael,

    I had the entries in the IFD tool back-to-front. The CRM is available from the intranet now.

    I have to make a new DNS record with our ISP now.

    Thanks

    Derek
    Derek
    Tuesday, July 21, 2009 6:59 PM
  • Thanks ckeller,

    Our CRM server is on a Windows Server 2003 machine, and I don't think IPv6 is configured.

    Good information though.

    Thanks

    Derek
    Derek
    Tuesday, July 21, 2009 7:02 PM