locked
Win7 Can't connect to WHS after setting static IP RRS feed

  • Question

  • I installed WHS & PP3 last week to use with my Win7 laptop and Vista desktop (will upgrade to Win7 soon). WHS was set up with remote access turned off, and by default, was issued a DHCP IP address from my Linksys WRT54G router (running DD-WRT). All machines connected perfectly, and got backed up for several days. I had this great idea to turn on remote desktop, and somewhere had read that WHS should be on a static IP, so I went through network connections, selected TCP/IP, and changed the DHCP to Static IP. Rebooted, and off I went...

    Now the Win7 laptop  (must stay as DHCP for roaming) won't connect to the WHS, yet the Vista desktop (static IP) can. I can ping the WHS from the Win7 laptop, so there is connectivity. I can also access the WHS from the internet using https://servername.homeserver.com, so I believe the router is configured correctly. I also tried re-installing the WHS connector software, but it couldn't find the WHS. servername:55000 was also coming up bad from the Win7 box (but fine from the Vista desktop). 
    Wednesday, November 4, 2009 5:46 PM

All replies

  • More testing - If I entered the IP address rather than the name, I can RDP to it, or http to port 55000...
    Thursday, November 5, 2009 1:57 AM
  • if you ping the server by name from the client - what for an IP address is shown, the old, the new, a wrong one or none? Did you alter the hosts file on the client in the past?
    Did you ever reboot the client after changing the server IP?
    (Or at least enter the command ipconfig /flushdns in an Administrator command prompt)?
    Best greetings from Germany
    Olaf
    Thursday, November 5, 2009 7:53 AM
    Moderator
  • Probably you have a name resolution problem related to network configuration on the Windows 7 laptop. Compare the IP addresses you see when you ping your server by name from the Windows 7 computer and the Windows Vista computer. Also compare the results of ipconfig /all on the two computers.

    I'm not on the WHS team, I just post a lot. :)
    Thursday, November 5, 2009 4:24 PM
    Moderator